summaryrefslogtreecommitdiff
path: root/gnu/system
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2015-09-03 12:51:47 -0400
committerMark H Weaver <mhw@netris.org>2015-09-03 12:57:01 -0400
commit92226a470ddc980e54863632e5b179bf40444bd7 (patch)
treea1336ed5da129fcb33b8a51c0ff39602fb58702b /gnu/system
parent52c20d8e1517190ca5bfbaa9f83da17587b47e9c (diff)
downloadguix-patches-92226a470ddc980e54863632e5b179bf40444bd7.tar
guix-patches-92226a470ddc980e54863632e5b179bf40444bd7.tar.gz
Build tarballs with deterministic file ordering.
* guix/packages.scm (patch-and-repack)[build], gnu/system/install.scm (self-contained-tarball)[build], gnu/packages/make-bootstrap.scm (tarball-package), gnu/packages/admin.scm (isc-dhcp), gnu/packages/video.scm (avidemux): Pass "--sort=name" to 'tar'.
Diffstat (limited to 'gnu/system')
-rw-r--r--gnu/system/install.scm7
1 files changed, 6 insertions, 1 deletions
diff --git a/gnu/system/install.scm b/gnu/system/install.scm
index e7e5d4ae9d..880236861e 100644
--- a/gnu/system/install.scm
+++ b/gnu/system/install.scm
@@ -74,8 +74,13 @@ under /root/.guix-profile where GUIX is installed."
;; length limitation.
(with-directory-excursion %root
(zero? (system* "tar" "--xz" "--format=gnu"
- "--owner=root:0" "--group=root:0"
+
+ ;; avoid non-determinism in the archive
+ "--sort=name"
"--mtime=@0" ;for files in /var/guix
+ "--owner=root:0"
+ "--group=root:0"
+
"--check-links"
"-cvf" #$output
;; Avoid adding / and /var to the tarball,