summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2015-09-03 12:51:47 -0400
committerMark H Weaver <mhw@netris.org>2015-09-03 12:57:01 -0400
commit92226a470ddc980e54863632e5b179bf40444bd7 (patch)
treea1336ed5da129fcb33b8a51c0ff39602fb58702b
parent52c20d8e1517190ca5bfbaa9f83da17587b47e9c (diff)
downloadguix-patches-92226a470ddc980e54863632e5b179bf40444bd7.tar
guix-patches-92226a470ddc980e54863632e5b179bf40444bd7.tar.gz
Build tarballs with deterministic file ordering.
* guix/packages.scm (patch-and-repack)[build], gnu/system/install.scm (self-contained-tarball)[build], gnu/packages/make-bootstrap.scm (tarball-package), gnu/packages/admin.scm (isc-dhcp), gnu/packages/video.scm (avidemux): Pass "--sort=name" to 'tar'.
-rw-r--r--gnu/packages/admin.scm1
-rw-r--r--gnu/packages/make-bootstrap.scm3
-rw-r--r--gnu/packages/video.scm3
-rw-r--r--gnu/system/install.scm7
-rw-r--r--guix/packages.scm1
5 files changed, 12 insertions, 3 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 53cf65e11a..512d604982 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -428,6 +428,7 @@ connection alive.")
(zero? (system* "tar" "cf" "bind.tar.gz"
"bind-9.9.5-P1"
;; avoid non-determinism in the archive
+ "--sort=name"
"--mtime=@0"
"--owner=root:0"
"--group=root:0"))))
diff --git a/gnu/packages/make-bootstrap.scm b/gnu/packages/make-bootstrap.scm
index 904aaedb73..d215a02ff0 100644
--- a/gnu/packages/make-bootstrap.scm
+++ b/gnu/packages/make-bootstrap.scm
@@ -629,7 +629,8 @@ for `sh' in $PATH, and without nscd, and with static NSS modules."
".tar.xz")
"."
;; avoid non-determinism in the archive
- "--mtime=@0" "--owner=root:0" "--group=root:0"))))))))))
+ "--sort=name" "--mtime=@0"
+ "--owner=root:0" "--group=root:0"))))))))))
(define %bootstrap-binaries-tarball
;; A tarball with the statically-linked bootstrap binaries.
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 79119ef43a..c2f88e22cc 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -1015,7 +1015,8 @@ for use with HTML5 video.")
(("#! /bin/sh") (string-append "#!" (which "bash"))))
(system* "tar" "cjf" "ffmpeg-2.6.1.tar.bz2" "ffmpeg-2.6.1"
;; avoid non-determinism in the archive
- "--mtime=@0" "--owner=root:0" "--group=root:0")
+ "--sort=name" "--mtime=@0"
+ "--owner=root:0" "--group=root:0")
(delete-file-recursively "ffmpeg-2.6.1")))
(alist-replace 'configure
(lambda _
diff --git a/gnu/system/install.scm b/gnu/system/install.scm
index e7e5d4ae9d..880236861e 100644
--- a/gnu/system/install.scm
+++ b/gnu/system/install.scm
@@ -74,8 +74,13 @@ under /root/.guix-profile where GUIX is installed."
;; length limitation.
(with-directory-excursion %root
(zero? (system* "tar" "--xz" "--format=gnu"
- "--owner=root:0" "--group=root:0"
+
+ ;; avoid non-determinism in the archive
+ "--sort=name"
"--mtime=@0" ;for files in /var/guix
+ "--owner=root:0"
+ "--group=root:0"
+
"--check-links"
"-cvf" #$output
;; Avoid adding / and /var to the tarball,
diff --git a/guix/packages.scm b/guix/packages.scm
index d338ad230b..d73e6b0abb 100644
--- a/guix/packages.scm
+++ b/guix/packages.scm
@@ -482,6 +482,7 @@ IMPORTED-MODULES specify modules to use/import for use by SNIPPET."
(zero? (system* (string-append #+tar "/bin/tar")
"cvfa" #$output directory
;; avoid non-determinism in the archive
+ "--sort=name"
"--mtime=@0"
"--owner=root:0"
"--group=root:0")))))))