summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorTimotej Lazar <timotej.lazar@araneo.si>2021-08-04 12:49:31 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-08-05 09:02:29 +0200
commitfd85c59d1e7e6111e9c625930c633994c66075eb (patch)
treebfbeefcb267fb8a85dabb00b54cd8fd317888eb6 /gnu/packages
parent79eb05f84f41ef777d1afa595a9044b36cf93896 (diff)
downloadguix-patches-fd85c59d1e7e6111e9c625930c633994c66075eb.tar
guix-patches-fd85c59d1e7e6111e9c625930c633994c66075eb.tar.gz
gnu: endless-sky: Clean up phases.
* gnu/packages/games.scm (endless-sky)[arguments]: Drop unused substitution and merge existing phases into 'fix-paths. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/games.scm14
1 files changed, 4 insertions, 10 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index e46d9402e5..8d9550ac0d 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -8368,19 +8368,13 @@ your score gets higher, you level up and the blocks fall faster.")
#:tests? #f ; no tests
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'patch-resource-locations
+ (add-after 'unpack 'fix-paths
(lambda* (#:key outputs #:allow-other-keys)
+ ;; Look for resources in the store directory.
(substitute* "source/Files.cpp"
- (("/usr/local/")
- (string-append (assoc-ref outputs "out") "/")))
- #t))
- (add-after 'unpack 'patch-scons
- (lambda _
+ (("/usr/local") (assoc-ref outputs "out")))
+ ;; Install game binary into %out/bin.
(substitute* "SConstruct"
- ;; Keep environmental variables
- (("Environment\\(\\)")
- "Environment(ENV = os.environ)")
- ;; Install into %out/bin
(("games\"") "bin\""))
#t))
(add-before 'build 'use-gcc-ar