summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorTimotej Lazar <timotej.lazar@araneo.si>2021-08-04 12:49:30 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-08-05 09:01:58 +0200
commit79eb05f84f41ef777d1afa595a9044b36cf93896 (patch)
tree2faadfc74f23293292f357f9e5048494ec7da460 /gnu/packages
parent8b4a654ab914a08a53dfc81eff1be738ce6e58b2 (diff)
downloadguix-patches-79eb05f84f41ef777d1afa595a9044b36cf93896.tar
guix-patches-79eb05f84f41ef777d1afa595a9044b36cf93896.tar.gz
gnu: endless-sky: Update to 0.9.14.
* gnu/packages/games.scm (endless-sky): Update to 0.9.14. [arguments]: Add 'use-gcc-ar phase to support LTO used by the new version. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/games.scm9
1 files changed, 6 insertions, 3 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 768a08a238..e46d9402e5 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -8351,7 +8351,7 @@ your score gets higher, you level up and the blocks fall faster.")
(define-public endless-sky
(package
(name "endless-sky")
- (version "0.9.12")
+ (version "0.9.14")
(source
(origin
(method git-fetch)
@@ -8360,7 +8360,7 @@ your score gets higher, you level up and the blocks fall faster.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "18nkl4s3r5sy3sd9lhbdg9160c7fggklklprx0d5azifc8g6k0wj"))))
+ (base32 "12iganf8dxiyrjznnabsarxjsr0h717j3k4mz15p0k67wxyahhmf"))))
(build-system scons-build-system)
(arguments
`(#:scons ,scons-python2
@@ -8382,7 +8382,10 @@ your score gets higher, you level up and the blocks fall faster.")
"Environment(ENV = os.environ)")
;; Install into %out/bin
(("games\"") "bin\""))
- #t)))))
+ #t))
+ (add-before 'build 'use-gcc-ar
+ ;; Use gcc-ar to support LTO.
+ (lambda _ (setenv "AR" "gcc-ar"))))))
(inputs
`(("glew" ,glew)
("libjpeg" ,libjpeg-turbo)