summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-05-13 13:57:03 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:10:47 +0200
commit97188ba798edfbf490477746636faad24451ff45 (patch)
treeb308f4295b2789c928ac5a3e846fad4382c90139 /gnu/packages
parent48beed24ffe98092d1857f34201034db837ff15e (diff)
downloadguix-patches-97188ba798edfbf490477746636faad24451ff45.tar
guix-patches-97188ba798edfbf490477746636faad24451ff45.tar.gz
gnu: Add texlive-atenddvi.
* gnu/packages/tex.scm (texlive-atenddvi): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/tex.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index dadc0165cf..5489aa9f9a 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -3228,6 +3228,33 @@ with the required packages, constitutes what every LaTeX distribution should
contain.")
(license license:lppl1.3c+))))
+(define-public texlive-atenddvi
+ (package
+ (name "texlive-atenddvi")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/atenddvi/"
+ "source/latex/atenddvi/"
+ "tex/latex/atenddvi/")
+ (base32
+ "1fwa5233mdgvixhl2rzn9s06zz52j6ml7hfzd4194bn389n9syhk")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (propagated-inputs
+ (list texlive-atbegshi texlive-zref))
+ (home-page "https://ctan.org/pkg/atenddvi")
+ (synopsis "Provide the @code{\\AtEndDvi} command for older LaTeX format")
+ (description
+ "This package is unneeded and does nothing when used with a LaTeX format
+2020-10-01 or newer as in this case the format provides the @code{\\AtEndDvi}
+command. For older formats it implements @code{\\AtEndDvi}, a counterpart to
+@code{\\AtBeginDvi}. The execution of its argument is delayed to the end of
+the document at the end of the last page. Thus @code{\\special} and
+@code{\\write} remain effective, because they are put into the last page.
+This is the main difference to @code{\\AtEndDocument}.")
+ (license license:lppl1.3c+)))
+
(define-public texlive-attachfile
(package
(name "texlive-attachfile")