summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-05-13 12:12:44 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:10:46 +0200
commit48beed24ffe98092d1857f34201034db837ff15e (patch)
treef61f5614d86b6378c5be3e0cd1664275b072fab3 /gnu/packages
parent5c7700fc051b28bf9e8eb4a16f68f4a7c50152cb (diff)
downloadguix-patches-48beed24ffe98092d1857f34201034db837ff15e.tar
guix-patches-48beed24ffe98092d1857f34201034db837ff15e.tar.gz
gnu: texlive-latex-appendix -> texlive-appendix.
* gnu/packages/tex.scm (texlive-appendix): New variable. (texlive-latex-appendix): Deprecate variable. * gnu/packages/docbook.scm (dblatex): Use new name.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/docbook.scm2
-rw-r--r--gnu/packages/tex.scm36
2 files changed, 20 insertions, 18 deletions
diff --git a/gnu/packages/docbook.scm b/gnu/packages/docbook.scm
index 86c130860c..4ccae3f252 100644
--- a/gnu/packages/docbook.scm
+++ b/gnu/packages/docbook.scm
@@ -536,7 +536,7 @@ the in DocBook SGML DTDs.")
(inputs
`(("texlive" ,(texlive-updmap.cfg (list texlive-amsfonts
texlive-anysize
- texlive-latex-appendix
+ texlive-appendix
texlive-latex-bookmark
texlive-latex-changebar
texlive-latex-colortbl
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index b496dab8fd..dadc0165cf 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -6465,28 +6465,30 @@ considered obsolete; alternatives are the @code{typearea} package from the
(define-deprecated-package texlive-latex-anysize texlive-anysize)
-(define-public texlive-latex-appendix
+(define-public texlive-appendix
(package
- (name "texlive-latex-appendix")
+ (name "texlive-appendix")
(version (number->string %texlive-revision))
- (source (origin
- (method svn-fetch)
- (uri (texlive-ref "latex" "appendix"))
- (file-name (string-append name "-" version "-checkout"))
- (sha256
- (base32
- "1gc2brr2rs495w7qi6spdva1xrza94x7a36dncjdkghnsq8r92h4"))))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/appendix/"
+ "source/latex/appendix/"
+ "tex/latex/appendix/")
+ (base32
+ "1vqkqpzs7bc6pbjnafakrwayjyfx9mvadrqxccdf549m8172qvzk")))
+ (outputs '("out" "doc"))
(build-system texlive-build-system)
- (arguments '(#:tex-directory "latex/appendix"))
- (home-page "https://www.ctan.org/pkg/appendix")
+ (home-page "https://ctan.org/pkg/appendix")
(synopsis "Extra control of appendices")
(description
- "The appendix package provides various ways of formatting the titles of
-appendices. Also (sub)appendices environments are provided that can be used,
-for example, for per chapter/section appendices. An @code{appendices}
-environment is provided which can be used instead of the @code{\\appendix}
-command.")
- (license license:lppl)))
+ "The @code{appendix} package provides various ways of formatting the
+titles of appendices. Also (sub)appendices environments are provided that can
+be used, for example, for per chapter/section appendices. An
+@code{appendices} environment is provided which can be used instead of the
+@code{\\appendix} command.")
+ (license license:lppl1.3c)))
+
+(define-deprecated-package texlive-latex-appendix texlive-appendix)
(define-public texlive-latex-bookmark
(package