summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2016-10-16 19:32:06 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2016-11-15 22:31:36 +0100
commit6aa5f1ca240b6daf4dbc5c3031fdd697119a49ea (patch)
treef704e2a2148ff269139a4fd3aeb2b3a4f2f80b8f /gnu/packages
parentbb06aa344656b044f83cc2f0ac4c7bcbf5cd10e6 (diff)
downloadguix-patches-6aa5f1ca240b6daf4dbc5c3031fdd697119a49ea.tar
guix-patches-6aa5f1ca240b6daf4dbc5c3031fdd697119a49ea.tar.gz
gnu: python-joblib: Remove python byte-code files from source.
* gnu/packages/python.scm (python-joblib, python2-joblib)[source]: Add snippet.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python.scm10
1 files changed, 9 insertions, 1 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 117e845672..8190a3bd2b 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -2649,7 +2649,15 @@ logic-free templating system Mustache.")
(uri (pypi-uri "joblib" version))
(sha256
(base32
- "0787k919zlfmgymprz5bzv0v1df5bbirlf3awrghmjgvkrd9dci9"))))
+ "0787k919zlfmgymprz5bzv0v1df5bbirlf3awrghmjgvkrd9dci9"))
+ (modules '((guix build utils)))
+ (snippet
+ '(begin
+ ;; Remove pre-compiled .pyc files from source.
+ (for-each delete-file-recursively
+ (find-files "." "__pycache__" #:directories? #t))
+ (for-each delete-file (find-files "." "\\.pyc$"))
+ #t))))
(build-system python-build-system)
(arguments
`(#:phases