summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2016-10-16 19:26:33 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2016-11-15 22:31:35 +0100
commitbb06aa344656b044f83cc2f0ac4c7bcbf5cd10e6 (patch)
tree1498d8e9995a536d254091f85b7a669005dd8fee /gnu/packages
parent130fe99410e52eb647c8fcff8e2de1c6b0b7575a (diff)
downloadguix-patches-bb06aa344656b044f83cc2f0ac4c7bcbf5cd10e6.tar
guix-patches-bb06aa344656b044f83cc2f0ac4c7bcbf5cd10e6.tar.gz
gnu: python-oauthlib, python-oauthlib2: Correct inputs.
* gnu/packages/python.scm (python-oauthlib) [propagated-inputs] Move all to [native-inputs]. [native-inputs]: Remove python-mock, python-coverage. (python2-oauthlib)[native-inputs]: Add python2-mock.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python.scm10
1 files changed, 4 insertions, 6 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 8213e83fb1..117e845672 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -2464,13 +2464,10 @@ somewhat intelligeble.")
"1bfrj70vdjxjw74khbyh6f0dksv7p5rh2346jnlrffyacd3gwjzg"))))
(build-system python-build-system)
(native-inputs
- `(("python-coverage" ,python-coverage)
- ("python-nose" ,python-nose)
- ("python-mock" ,python-mock)))
- (propagated-inputs
- `(("python-blinker" ,python-blinker)
+ `(("python-nose" ,python-nose)
("python-cryptography" ,python-cryptography)
- ("python-pyjwt" ,python-pyjwt)))
+ ("python-pyjwt" ,python-pyjwt)
+ ("python-blinker" ,python-blinker)))
(home-page "https://github.com/idan/oauthlib")
(synopsis "OAuth implementation for Python")
(description
@@ -2484,6 +2481,7 @@ OAuth request-signing logic.")
(package
(inherit base)
(native-inputs `(("python2-unittest2" ,python2-unittest2)
+ ("python2-mock" ,python2-mock)
,@(package-native-inputs base))))))
(define-public python-itsdangerous