summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-02-15 14:30:57 +0100
committerMarius Bakke <mbakke@fastmail.com>2019-02-17 18:44:18 +0100
commit61506fe551ed2237754dcaef569fff4645cd1a9d (patch)
treecb38643820b6ee60a7c824c32e85f2663b0f2299 /gnu/packages
parent123d92eaf366cea36de218acc7fc052e13207921 (diff)
downloadguix-patches-61506fe551ed2237754dcaef569fff4645cd1a9d.tar
guix-patches-61506fe551ed2237754dcaef569fff4645cd1a9d.tar.gz
gnu: Remove unneeded uses of python{,2}-minimal.
The "python-minimal" package exists mostly to resolve a dependency cycle. To reduce duplication, packages should prefer the regular Python variants. * gnu/packages/admin.scm (htop)[native-inputs]: Change PYTHON-MINIMAL-WRAPPER to PYTHON-WRAPPER. * gnu/packages/crypto.scm (botan)[native-inputs]: Likewise. * gnu/packages/bioinformatics.scm (sambamba)[native-inputs]: Change PYTHON-MINIMAL to PYTHON. * gnu/packages/dictionaries.scm (apertium)[native-inputs]: Likewise. * gnu/packages/databases.scm (mongodb)[native-inputs]: Change PYTHON2-MINIMAL to PYTHON2. * gnu/packages/games.scm (openttd-opensfx, openttd-openmsx)[native-inputs]: Likewise. * gnu/packages/gnome.scm (deja-dup)[native-inputs]: Likewise.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/admin.scm2
-rw-r--r--gnu/packages/bioinformatics.scm2
-rw-r--r--gnu/packages/crypto.scm2
-rw-r--r--gnu/packages/databases.scm2
-rw-r--r--gnu/packages/dictionaries.scm2
-rw-r--r--gnu/packages/games.scm4
-rw-r--r--gnu/packages/gnome.scm2
7 files changed, 8 insertions, 8 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 3243459a04..4241490d48 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -298,7 +298,7 @@ graphs and can export its output to different formats.")
(inputs
`(("ncurses" ,ncurses)))
(native-inputs
- `(("python" ,python-minimal-wrapper))) ; for scripts/MakeHeader.py
+ `(("python" ,python-wrapper))) ; for scripts/MakeHeader.py
(home-page "https://hisham.hm/htop/")
(synopsis "Interactive process viewer")
(description
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 933b8b9adf..69c85563e1 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -11192,7 +11192,7 @@ droplet sequencing. It has been particularly tailored for Drop-seq.")
(native-inputs
`(("ldc" ,ldc)
("rdmd" ,rdmd)
- ("python" ,python-minimal)
+ ("python" ,python)
("biod"
,(let ((commit "4f1a7d2fb7ef3dfe962aa357d672f354ebfbe42e"))
(origin
diff --git a/gnu/packages/crypto.scm b/gnu/packages/crypto.scm
index ffef4ff8e4..0345a59285 100644
--- a/gnu/packages/crypto.scm
+++ b/gnu/packages/crypto.scm
@@ -751,7 +751,7 @@ SHA256, SHA512, SHA3, AICH, ED2K, Tiger, DC++ TTH, BitTorrent BTIH, GOST R
(replace 'check
(lambda _ (invoke "./botan-test"))))))
(native-inputs
- `(("python" ,python-minimal-wrapper)
+ `(("python" ,python-wrapper)
("python-docutils" ,python-docutils)))
(inputs
`(("sqlite" ,sqlite)
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index 6129e3c0cb..e62e889f8c 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -335,7 +335,7 @@ applications.")
(native-inputs
`(("valgrind" ,valgrind)
("perl" ,perl)
- ("python" ,python2-minimal)
+ ("python" ,python-2)
("python2-pymongo" ,python2-pymongo)
("python2-pyyaml" ,python2-pyyaml)
("tzdata" ,tzdata)))
diff --git a/gnu/packages/dictionaries.scm b/gnu/packages/dictionaries.scm
index 8c39453650..e0cd7604b6 100644
--- a/gnu/packages/dictionaries.scm
+++ b/gnu/packages/dictionaries.scm
@@ -372,7 +372,7 @@ word (e.g. cats) into its lemma \"cat\" and the grammatical information
("flex" ,flex)
("pkg-config" ,pkg-config)
;; python is only required for running the test suite
- ("python-minimal" ,python-minimal)))
+ ("python" ,python)))
(arguments
`(#:phases
(modify-phases %standard-phases
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index f82af0e8c3..0832b1ef63 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -2413,7 +2413,7 @@ OpenGFX provides you with...
(build-system gnu-build-system)
(native-inputs
`(("catcodec" ,catcodec)
- ("python" ,python2-minimal)))
+ ("python" ,python-2)))
(arguments
`(#:make-flags
(list (string-append "INSTALL_DIR=" %output
@@ -2450,7 +2450,7 @@ the original Transport Tycoon Deluxe.")
"0nskq97a6fsv1v6d62zf3yb8whzhqnlh3lap3va3nzvj7csjgf7c"))))
(build-system gnu-build-system)
(native-inputs
- `(("python" ,python2-minimal)))
+ `(("python" ,python-2)))
(arguments
`(#:make-flags
(list (string-append "INSTALL_DIR=" %output
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 7001a12b19..e371a60131 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -277,7 +277,7 @@ features to enable users to create their discs easily and quickly.")
`(("gsettings-desktop-schemas" ,gsettings-desktop-schemas)
("gobject-introspection" ,gobject-introspection)
("duplicity" ,duplicity)
- ("python" ,python2-minimal)
+ ("python" ,python-2)
("python-pygobject" ,python2-pygobject)
("gtk+" ,gtk+)
("libnotify" ,libnotify)