summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorpukkamustard <pukkamustard@posteo.net>2022-08-22 09:54:38 +0000
committerJulien Lepiller <julien@lepiller.eu>2022-08-24 18:21:44 +0200
commit1cb6064b49c52657f02ccea843dab4bc66ebb471 (patch)
tree9ec400b91b649e23a7771bed1920d688a4cade11 /gnu/packages
parent4719f43841907610ffdcda8364f7c36e32497930 (diff)
downloadguix-patches-1cb6064b49c52657f02ccea843dab4bc66ebb471.tar
guix-patches-1cb6064b49c52657f02ccea843dab4bc66ebb471.tar.gz
gnu: Add ocaml-eqaf.
* gnu/packages/ocaml.scm (ocaml-eqaf): New variable. Signed-off-by: Julien Lepiller <julien@lepiller.eu>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/ocaml.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index ac5eb4b239..b070ee7748 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -8655,6 +8655,29 @@ QuickCheck-style property-based testing and the magical bug-finding powers of
@uref{http://lcamtuf.coredump.cx/afl/, afl-fuzz}.")
(license license:expat)))
+(define-public ocaml-eqaf
+ (package
+ (name "ocaml-eqaf")
+ (version "0.9")
+ (home-page "https://github.com/mirage/eqaf")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url home-page)
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "16ics56wiqyng70dy2hqikicm8ag1mv5w1h7hkiwvydw1x2j2rsl"))))
+ (build-system dune-build-system)
+ (propagated-inputs (list ocaml-cstruct))
+ (native-inputs (list ocaml-alcotest ocaml-crowbar))
+ (synopsis "OCaml library for constant-time equal function on string")
+ (description "This OCaml library provides an equal function on string in
+constant-time to avoid timing-attack with crypto stuff.")
+ (license license:expat)))
+
(define-public ocaml-bibtex2html
(package
(name "ocaml-bibtex2html")