summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorpukkamustard <pukkamustard@posteo.net>2022-08-22 09:54:37 +0000
committerJulien Lepiller <julien@lepiller.eu>2022-08-24 18:21:27 +0200
commit4719f43841907610ffdcda8364f7c36e32497930 (patch)
treee85f86591453de4a13b00606b8a87d80424b4c7a /gnu/packages
parent3d403f56dd52a46e0ca119a67552e82896aee3b4 (diff)
downloadguix-patches-4719f43841907610ffdcda8364f7c36e32497930.tar
guix-patches-4719f43841907610ffdcda8364f7c36e32497930.tar.gz
gnu: Add ocaml-crowbar.
* gnu/packages/ocaml.scm (ocaml-crowbar): New variable. Signed-off-by: Julien Lepiller <julien@lepiller.eu>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/ocaml.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 3572b36881..ac5eb4b239 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -8620,6 +8620,41 @@ breaks, while respecting the constraints imposed by the structure of the
document and by the text width.")
(license license:lgpl2.0)))
+(define-public ocaml-crowbar
+ (package
+ (name "ocaml-crowbar")
+ (version "0.2.1")
+ (home-page "https://github.com/stedolan/crowbar")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url home-page)
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "11f3kiw58g8njx15akx16xcplzvzdw9y6c4jpyfxylkxws4g0f6j"))))
+ (build-system dune-build-system)
+ (arguments
+ `(#:test-target "."))
+ (propagated-inputs
+ (list ocaml-ocplib-endian
+ ocaml-cmdliner
+ ocaml-afl-persistent))
+ (native-inputs
+ (list ocaml-calendar
+ ocaml-fpath
+ ocaml-uucp
+ ocaml-uunf
+ ocaml-uutf
+ ocaml-pprint))
+ (synopsis "Ocaml library for tests, let a fuzzer find failing cases")
+ (description "Crowbar is a library for testing code, combining
+QuickCheck-style property-based testing and the magical bug-finding powers of
+@uref{http://lcamtuf.coredump.cx/afl/, afl-fuzz}.")
+ (license license:expat)))
+
(define-public ocaml-bibtex2html
(package
(name "ocaml-bibtex2html")