summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2021-04-27 00:19:42 -0400
committerLeo Famulari <leo@famulari.name>2021-04-27 01:07:54 -0400
commit0cb4ef1c7f8b2f14f1dfa588949fb16b918731c5 (patch)
tree420540cc96cbfad63824bf670ead830b98ec2b4d /gnu/packages
parent67928ad4c24538e4e49e23e524fa6ffef6e55f51 (diff)
downloadguix-patches-0cb4ef1c7f8b2f14f1dfa588949fb16b918731c5.tar
guix-patches-0cb4ef1c7f8b2f14f1dfa588949fb16b918731c5.tar.gz
gnu: GIMP: Update to 2.10.24.
* gnu/packages/gimp.scm (gimp): Update to 2.10.24. [source]: Remove obsolete patch 'gimp-make-gegl-introspect-optional.patch'. * gnu/packages/patches/gimp-make-gegl-introspect-optional.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove it.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/gimp.scm5
-rw-r--r--gnu/packages/patches/gimp-make-gegl-introspect-optional.patch43
2 files changed, 2 insertions, 46 deletions
diff --git a/gnu/packages/gimp.scm b/gnu/packages/gimp.scm
index f8ffe19433..2da57ee8ee 100644
--- a/gnu/packages/gimp.scm
+++ b/gnu/packages/gimp.scm
@@ -269,7 +269,7 @@ buffers.")
(define-public gimp
(package
(name "gimp")
- (version "2.10.22")
+ (version "2.10.24")
(source
(origin
(method url-fetch)
@@ -277,8 +277,7 @@ buffers.")
(version-major+minor version)
"/gimp-" version ".tar.bz2"))
(sha256
- (base32 "1fqqyshakvdarf1jipk2n33ibqr23ni22z3d8srq13bpydblpf1d"))
- (patches (search-patches "gimp-make-gegl-introspect-optional.patch"))))
+ (base32 "17lq6ns5qhspd171zqh76yf98xnn5n0hcl7hbhbx63cc6ribf6xx"))))
(build-system gnu-build-system)
(outputs '("out"
"doc")) ; 9 MiB of gtk-doc HTML
diff --git a/gnu/packages/patches/gimp-make-gegl-introspect-optional.patch b/gnu/packages/patches/gimp-make-gegl-introspect-optional.patch
deleted file mode 100644
index 4dd1ab74a8..0000000000
--- a/gnu/packages/patches/gimp-make-gegl-introspect-optional.patch
+++ /dev/null
@@ -1,43 +0,0 @@
-From 2cae9b9acf9da98c4c9990819ffbd5aabe23017e Mon Sep 17 00:00:00 2001
-From: Jehan <jehan@girinstud.io>
-Date: Mon, 14 Dec 2020 19:53:38 +0100
-Subject: [PATCH] app: make "gegl:introspect" an optional operation dependency.
-
-Check at runtime for the operation availability and set the "Show Image
-Graph" action active depending on this check.
-
-This goes with discussions to make this operation optional with a
-runtime check for the tool `dot`.
-See: https://gitlab.gnome.org/GNOME/gegl/-/merge_requests/84
----
- app/actions/debug-actions.c | 6 ++++++
- app/sanity.c | 1 -
- 2 files changed, 6 insertions(+), 1 deletion(-)
-
-diff --git a/app/actions/debug-actions.c b/app/actions/debug-actions.c
-index 6be4422b228..22ca38b15ea 100644
---- a/app/actions/debug-actions.c
-+++ b/app/actions/debug-actions.c
-@@ -103,4 +103,10 @@ void
- debug_actions_update (GimpActionGroup *group,
- gpointer data)
- {
-+#define SET_SENSITIVE(action,condition) \
-+ gimp_action_group_set_action_sensitive (group, action, (condition) != 0)
-+
-+ SET_SENSITIVE ("debug-show-image-graph", gegl_has_operation ("gegl:introspect"));
-+
-+#undef SET_SENSITIVE
- }
-diff --git a/app/sanity.c b/app/sanity.c
-index 015801a396e..6374ac1ad20 100644
---- a/app/sanity.c
-+++ b/app/sanity.c
-@@ -650,7 +650,6 @@ sanity_check_gegl_ops (void)
- "gegl:hue-chroma",
- "gegl:illusion",
- "gegl:image-gradient",
-- "gegl:introspect",
- "gegl:invert-gamma",
- "gegl:invert-linear",
- "gegl:lens-blur",