summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/gimp.scm5
-rw-r--r--gnu/packages/patches/gimp-make-gegl-introspect-optional.patch43
3 files changed, 2 insertions, 47 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index e8b6effb36..c4d757bc89 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1085,7 +1085,6 @@ dist_patch_DATA = \
%D%/packages/patches/ghostscript-no-header-id.patch \
%D%/packages/patches/ghostscript-no-header-uuid.patch \
%D%/packages/patches/ghostscript-no-header-creationdate.patch \
- %D%/packages/patches/gimp-make-gegl-introspect-optional.patch \
%D%/packages/patches/glib-appinfo-watch.patch \
%D%/packages/patches/glib-tests-timer.patch \
%D%/packages/patches/glib-CVE-2021-27218.patch \
diff --git a/gnu/packages/gimp.scm b/gnu/packages/gimp.scm
index f8ffe19433..2da57ee8ee 100644
--- a/gnu/packages/gimp.scm
+++ b/gnu/packages/gimp.scm
@@ -269,7 +269,7 @@ buffers.")
(define-public gimp
(package
(name "gimp")
- (version "2.10.22")
+ (version "2.10.24")
(source
(origin
(method url-fetch)
@@ -277,8 +277,7 @@ buffers.")
(version-major+minor version)
"/gimp-" version ".tar.bz2"))
(sha256
- (base32 "1fqqyshakvdarf1jipk2n33ibqr23ni22z3d8srq13bpydblpf1d"))
- (patches (search-patches "gimp-make-gegl-introspect-optional.patch"))))
+ (base32 "17lq6ns5qhspd171zqh76yf98xnn5n0hcl7hbhbx63cc6ribf6xx"))))
(build-system gnu-build-system)
(outputs '("out"
"doc")) ; 9 MiB of gtk-doc HTML
diff --git a/gnu/packages/patches/gimp-make-gegl-introspect-optional.patch b/gnu/packages/patches/gimp-make-gegl-introspect-optional.patch
deleted file mode 100644
index 4dd1ab74a8..0000000000
--- a/gnu/packages/patches/gimp-make-gegl-introspect-optional.patch
+++ /dev/null
@@ -1,43 +0,0 @@
-From 2cae9b9acf9da98c4c9990819ffbd5aabe23017e Mon Sep 17 00:00:00 2001
-From: Jehan <jehan@girinstud.io>
-Date: Mon, 14 Dec 2020 19:53:38 +0100
-Subject: [PATCH] app: make "gegl:introspect" an optional operation dependency.
-
-Check at runtime for the operation availability and set the "Show Image
-Graph" action active depending on this check.
-
-This goes with discussions to make this operation optional with a
-runtime check for the tool `dot`.
-See: https://gitlab.gnome.org/GNOME/gegl/-/merge_requests/84
----
- app/actions/debug-actions.c | 6 ++++++
- app/sanity.c | 1 -
- 2 files changed, 6 insertions(+), 1 deletion(-)
-
-diff --git a/app/actions/debug-actions.c b/app/actions/debug-actions.c
-index 6be4422b228..22ca38b15ea 100644
---- a/app/actions/debug-actions.c
-+++ b/app/actions/debug-actions.c
-@@ -103,4 +103,10 @@ void
- debug_actions_update (GimpActionGroup *group,
- gpointer data)
- {
-+#define SET_SENSITIVE(action,condition) \
-+ gimp_action_group_set_action_sensitive (group, action, (condition) != 0)
-+
-+ SET_SENSITIVE ("debug-show-image-graph", gegl_has_operation ("gegl:introspect"));
-+
-+#undef SET_SENSITIVE
- }
-diff --git a/app/sanity.c b/app/sanity.c
-index 015801a396e..6374ac1ad20 100644
---- a/app/sanity.c
-+++ b/app/sanity.c
-@@ -650,7 +650,6 @@ sanity_check_gegl_ops (void)
- "gegl:hue-chroma",
- "gegl:illusion",
- "gegl:image-gradient",
-- "gegl:introspect",
- "gegl:invert-gamma",
- "gegl:invert-linear",
- "gegl:lens-blur",