summaryrefslogtreecommitdiff
path: root/gnu/packages/xml.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-12-04 23:33:09 +0100
committerMarius Bakke <mbakke@fastmail.com>2019-12-05 17:59:09 +0100
commit785fcb62fecde1c275fd5bd5da488ef345f456d9 (patch)
treeaa94a6b8d4e2a69d7e5c88de89775bd58975a021 /gnu/packages/xml.scm
parent9092e3e936c747932140e7a5389219ee8c4580f6 (diff)
downloadguix-patches-785fcb62fecde1c275fd5bd5da488ef345f456d9.tar
guix-patches-785fcb62fecde1c275fd5bd5da488ef345f456d9.tar.gz
gnu: Remove python-libxml2 workaround.
* gnu/packages/xml.scm (python-libxml2)[source]: New field. (python-libxml2/fixed): Remove variable. * gnu/packages/glib.scm (itstool/fixed): Remove variable. * gnu/packages/gnome.scm (gnumeric)[native-inputs]: Replace ITSTOOL/FIXED with ITSTOOL. (yelp-tools/fixed): Remove variable. * gnu/packages/mate.scm (mate-applets, mate-utils)[native-inputs]: Replace YELP-TOOLS/FIXED with YELP-TOOLS.
Diffstat (limited to 'gnu/packages/xml.scm')
-rw-r--r--gnu/packages/xml.scm17
1 files changed, 4 insertions, 13 deletions
diff --git a/gnu/packages/xml.scm b/gnu/packages/xml.scm
index cc21d315eb..6d1aa6f76c 100644
--- a/gnu/packages/xml.scm
+++ b/gnu/packages/xml.scm
@@ -166,9 +166,12 @@ project (but it is usable outside of the Gnome platform).")
(license license:x11)))
(define-public python-libxml2
- ;; TODO: Merge with 'python-libxml2/fixed' on the next rebuild cycle.
(package/inherit libxml2
(name "python-libxml2")
+ (source (origin
+ (inherit (package-source libxml2))
+ (patches (cons (search-patch "python-libxml2-utf8.patch")
+ (origin-patches (package-source libxml2))))))
(build-system python-build-system)
(outputs '("out"))
(arguments
@@ -194,18 +197,6 @@ project (but it is usable outside of the Gnome platform).")
(inputs `(("libxml2" ,libxml2)))
(synopsis "Python bindings for the libxml2 library")))
-(define-public python-libxml2/fixed
- ;; This variant fixes a crash when processing UTF-8 sequences:
- ;; <https://bugs.gnu.org/37468>
- ;; TODO: Merge with 'python-libxml2' on the next rebuild cycle.
- (package/inherit
- python-libxml2
- (version (string-append (package-version python-libxml2) "-1"))
- (source (origin
- (inherit (package-source libxml2))
- (patches (cons (search-patch "python-libxml2-utf8.patch")
- (origin-patches (package-source libxml2))))))))
-
(define-public python2-libxml2
(package-with-python2 python-libxml2))