summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-12-04 23:33:09 +0100
committerMarius Bakke <mbakke@fastmail.com>2019-12-05 17:59:09 +0100
commit785fcb62fecde1c275fd5bd5da488ef345f456d9 (patch)
treeaa94a6b8d4e2a69d7e5c88de89775bd58975a021 /gnu
parent9092e3e936c747932140e7a5389219ee8c4580f6 (diff)
downloadguix-patches-785fcb62fecde1c275fd5bd5da488ef345f456d9.tar
guix-patches-785fcb62fecde1c275fd5bd5da488ef345f456d9.tar.gz
gnu: Remove python-libxml2 workaround.
* gnu/packages/xml.scm (python-libxml2)[source]: New field. (python-libxml2/fixed): Remove variable. * gnu/packages/glib.scm (itstool/fixed): Remove variable. * gnu/packages/gnome.scm (gnumeric)[native-inputs]: Replace ITSTOOL/FIXED with ITSTOOL. (yelp-tools/fixed): Remove variable. * gnu/packages/mate.scm (mate-applets, mate-utils)[native-inputs]: Replace YELP-TOOLS/FIXED with YELP-TOOLS.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/glib.scm10
-rw-r--r--gnu/packages/gnome.scm13
-rw-r--r--gnu/packages/mate.scm4
-rw-r--r--gnu/packages/xml.scm17
4 files changed, 7 insertions, 37 deletions
diff --git a/gnu/packages/glib.scm b/gnu/packages/glib.scm
index eb37b9e824..ff5206e7fd 100644
--- a/gnu/packages/glib.scm
+++ b/gnu/packages/glib.scm
@@ -540,16 +540,6 @@ information in their documents, such as whether a particular element should be
translated.")
(license license:gpl3+)))
-(define-public itstool/fixed
- ;; This variant fixes a python-libxml2 crash when processing UTF-8
- ;; sequences: <https://bugs.gnu.org/37468>. Since the issue is quite rare,
- ;; create this variant here to avoid a full rebuild.
- (package/inherit
- itstool
- (inputs
- `(("python-libxml2" ,python-libxml2/fixed)
- ,@(alist-delete "python-libxml2" (package-inputs itstool))))))
-
(define dbus-glib
(package
(name "dbus-glib")
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index cddfd75cc0..108004434c 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -2388,7 +2388,7 @@ Hints specification (EWMH).")
`(("bison" ,bison)
("docbook-xml" ,docbook-xml)
("intltool" ,intltool)
- ("itstool" ,itstool/fixed) ;see <https://bugs.gnu.org/37468>
+ ("itstool" ,itstool)
("glib:bin" ,glib "bin")
("pkg-config" ,pkg-config)))
(home-page "http://www.gnumeric.org")
@@ -4893,17 +4893,6 @@ lifting is done by packages like yelp-xsl and itstool. This package just
wraps things up in a developer-friendly way.")
(license license:gpl2+)))
-(define-public yelp-tools/fixed
- ;; This variant fixes a python-libxml2 crash when processing UTF-8
- ;; sequences: <https://bugs.gnu.org/37468>. TODO: Remove this in
- ;; the next rebuild cycle.
- (hidden-package
- (package/inherit
- yelp-tools
- (propagated-inputs
- `(("itstool" ,itstool/fixed)
- ,@(alist-delete "itstool" (package-propagated-inputs yelp-tools)))))))
-
(define-public libgee
(package
(name "libgee")
diff --git a/gnu/packages/mate.scm b/gnu/packages/mate.scm
index d55d1b4461..ba90ccec73 100644
--- a/gnu/packages/mate.scm
+++ b/gnu/packages/mate.scm
@@ -565,7 +565,7 @@ assorted menu related utility programs.")
`(("pkg-config" ,pkg-config)
("intltool" ,intltool)
("libxslt" ,libxslt)
- ("yelp-tools" ,yelp-tools/fixed)
+ ("yelp-tools" ,yelp-tools)
("scrollkeeper" ,scrollkeeper)
("gettext" ,gettext-minimal)
("docbook-xml" ,docbook-xml)
@@ -1279,7 +1279,7 @@ can be used as backgrounds in the MATE Desktop environment.")
("pkg-config" ,pkg-config)
("scrollkeeper" ,scrollkeeper)
("xorgproto" ,xorgproto)
- ("yelp-tools" ,yelp-tools/fixed)))
+ ("yelp-tools" ,yelp-tools)))
(inputs
`(("atk" ,atk)
("cairo" ,cairo)
diff --git a/gnu/packages/xml.scm b/gnu/packages/xml.scm
index cc21d315eb..6d1aa6f76c 100644
--- a/gnu/packages/xml.scm
+++ b/gnu/packages/xml.scm
@@ -166,9 +166,12 @@ project (but it is usable outside of the Gnome platform).")
(license license:x11)))
(define-public python-libxml2
- ;; TODO: Merge with 'python-libxml2/fixed' on the next rebuild cycle.
(package/inherit libxml2
(name "python-libxml2")
+ (source (origin
+ (inherit (package-source libxml2))
+ (patches (cons (search-patch "python-libxml2-utf8.patch")
+ (origin-patches (package-source libxml2))))))
(build-system python-build-system)
(outputs '("out"))
(arguments
@@ -194,18 +197,6 @@ project (but it is usable outside of the Gnome platform).")
(inputs `(("libxml2" ,libxml2)))
(synopsis "Python bindings for the libxml2 library")))
-(define-public python-libxml2/fixed
- ;; This variant fixes a crash when processing UTF-8 sequences:
- ;; <https://bugs.gnu.org/37468>
- ;; TODO: Merge with 'python-libxml2' on the next rebuild cycle.
- (package/inherit
- python-libxml2
- (version (string-append (package-version python-libxml2) "-1"))
- (source (origin
- (inherit (package-source libxml2))
- (patches (cons (search-patch "python-libxml2-utf8.patch")
- (origin-patches (package-source libxml2))))))))
-
(define-public python2-libxml2
(package-with-python2 python-libxml2))