summaryrefslogtreecommitdiff
path: root/gnu/packages/xiph.scm
diff options
context:
space:
mode:
authorPaul van der Walt <paul@denknerd.org>2015-10-21 21:56:38 +0200
committerPaul van der Walt <paul@denknerd.org>2015-10-21 21:57:57 +0200
commita7aa4e2a64f53eff0c1d97a27e88e93fb83aedf0 (patch)
treed2627beee0be2e86763c4cfafcfd5465138ae0da /gnu/packages/xiph.scm
parent845b4f5b7b57ce947f13745c2556e141b434f6a6 (diff)
downloadguix-patches-a7aa4e2a64f53eff0c1d97a27e88e93fb83aedf0.tar
guix-patches-a7aa4e2a64f53eff0c1d97a27e88e93fb83aedf0.tar.gz
gnu: Add opusfile.
* gnu/packages/xiph.scm (opusfile): New variable.
Diffstat (limited to 'gnu/packages/xiph.scm')
-rw-r--r--gnu/packages/xiph.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/xiph.scm b/gnu/packages/xiph.scm
index c4db640d0f..705ebe1d73 100644
--- a/gnu/packages/xiph.scm
+++ b/gnu/packages/xiph.scm
@@ -4,6 +4,7 @@
;;; Copyright © 2013 David Thompson <dthompson2@worcester.edu>
;;; Copyright © 2014 Sree Harsha Totakura <sreeharsha@totakura.in>
;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
+;;; Copyright © 2015 Paul van der Walt <paul@denknerd.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -46,6 +47,7 @@
libkate
vorbis-tools
opus
+ opusfile
opus-tools))
(define libogg
@@ -341,6 +343,34 @@ decoding .opus files.")
(license license:bsd-3)
(home-page "http://www.opus-codec.org")))
+(define opusfile
+ (package
+ (name "opusfile")
+ (version "0.6")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://downloads.xiph.org/releases/opus/opusfile-" version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "19iys2kld75k0210b807i4illrdmj3cmmnrgxlc9y4vf6mxp2a14"))))
+ (build-system gnu-build-system)
+ (propagated-inputs
+ `(("opus" ,opus)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (inputs
+ `(("libogg" ,libogg)
+ ("openssl" ,openssl)))
+ (synopsis "Versatile audio codec")
+ (description
+ "The opusfile library provides seeking, decode, and playback of Opus
+streams in the Ogg container (.opus files) including over http(s) on posix and
+windows systems.")
+ (license license:bsd-3)
+ (home-page "http://www.opus-codec.org")))
+
(define-public icecast
(package
(name "icecast")