summaryrefslogtreecommitdiff
path: root/gnu/packages/xfce.scm
diff options
context:
space:
mode:
authorIngo Ruhnke <grumbel@gmail.com>2019-10-03 21:38:38 +0200
committerDanny Milosavljevic <dannym@scratchpost.org>2019-10-04 14:30:32 +0200
commite18bc5e0112c38fc67fa07b9bf34cbb5d1df4eca (patch)
treeee04f45bdc1c5edd1ca148235b6bb405b88cc392 /gnu/packages/xfce.scm
parent40f0181bf72982b51dc8910df83cb61d6afdbfd4 (diff)
downloadguix-patches-e18bc5e0112c38fc67fa07b9bf34cbb5d1df4eca.tar
guix-patches-e18bc5e0112c38fc67fa07b9bf34cbb5d1df4eca.tar.gz
gnu: Add xfce4-kbdleds-plugin.
* gnu/packages/xfce.scm (xfce4-kbdleds-plugin): New variable. Signed-off-by: Danny Milosavljevic <dannym@scratchpost.org>
Diffstat (limited to 'gnu/packages/xfce.scm')
-rw-r--r--gnu/packages/xfce.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/xfce.scm b/gnu/packages/xfce.scm
index f542b19227..13836cf4a5 100644
--- a/gnu/packages/xfce.scm
+++ b/gnu/packages/xfce.scm
@@ -1495,6 +1495,34 @@ The string can also contain markup to displayed an image, a bar, a
button and a personalized tooltip.")
(license gpl2+)))
+(define-public xfce4-kbdleds-plugin
+ (package
+ (name "xfce4-kbdleds-plugin")
+ (version "0.0.6")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://archive.xfce.org/src/panel-plugins/"
+ "xfce4-kbdleds-plugin/"
+ (version-major+minor version)
+ "/xfce4-kbdleds-plugin-" version ".tar.bz2"))
+ (sha256
+ (base32
+ "1k810asjjxwix1c7ixl7bqr97zc4j2mw7797gk49rjvv43bhla3d"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("intltool" ,intltool)
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("gtk+-2" ,gtk+-2)
+ ("libxfce4ui" ,libxfce4ui)
+ ("xfce4-panel" ,xfce4-panel)))
+ (home-page
+ "https://goodies.xfce.org/projects/panel-plugins/xfce4-kbdleds-plugin")
+ (synopsis "Display keyboard LEDs in the Xfce panel")
+ (description "This plugin shows the state of your keyboard LEDs:
+Caps, Scroll and Num Lock in Xfce panel.")
+ (license gpl2+)))
+
(define-public xfce4-mpc-plugin
(package
(name "xfce4-mpc-plugin")