summaryrefslogtreecommitdiff
path: root/gnu/packages/xfce.scm
diff options
context:
space:
mode:
authorIngo Ruhnke <grumbel@gmail.com>2019-10-03 21:38:37 +0200
committerDanny Milosavljevic <dannym@scratchpost.org>2019-10-04 14:30:23 +0200
commit40f0181bf72982b51dc8910df83cb61d6afdbfd4 (patch)
treed4250726028e1e8ed32c20c3e6aa9ad074cb5788 /gnu/packages/xfce.scm
parent3b04836ebbda1bec6dbc108e922a67320e5db86c (diff)
downloadguix-patches-40f0181bf72982b51dc8910df83cb61d6afdbfd4.tar
guix-patches-40f0181bf72982b51dc8910df83cb61d6afdbfd4.tar.gz
gnu: Add xfce4-genmon-plugin.
* gnu/packages/xfce.scm (xfce4-genmon-plugin): New variable. Signed-off-by: Danny Milosavljevic <dannym@scratchpost.org>
Diffstat (limited to 'gnu/packages/xfce.scm')
-rw-r--r--gnu/packages/xfce.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/xfce.scm b/gnu/packages/xfce.scm
index 3708f9d2ed..f542b19227 100644
--- a/gnu/packages/xfce.scm
+++ b/gnu/packages/xfce.scm
@@ -1464,6 +1464,37 @@ urgent limit that advise the user with a message. The icon button can
be clicked to open the chosen mount point.")
(license bsd-2)))
+(define-public xfce4-genmon-plugin
+ (package
+ (name "xfce4-genmon-plugin")
+ (version "4.0.2")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://archive.xfce.org/src/panel-plugins/"
+ "xfce4-genmon-plugin/"
+ (version-major+minor version)
+ "/xfce4-genmon-plugin-" version ".tar.bz2"))
+ (sha256
+ (base32
+ "1ai3pwgv61nv7i2dyrvncnc63r8kdjbkp40vp51vzak1dx924v15"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("intltool" ,intltool)
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("libxfce4ui" ,libxfce4ui)
+ ("xfce4-panel" ,xfce4-panel)))
+ (home-page
+ "https://goodies.xfce.org/projects/panel-plugins/xfce4-genmon-plugin")
+ (synopsis "Generic program output monitor for the Xfce panel")
+ (description "This plugin cyclically spawns the indicated
+script/program, captures its output (stdout) and displays the
+resulting string into the panel.
+
+The string can also contain markup to displayed an image, a bar, a
+button and a personalized tooltip.")
+ (license gpl2+)))
+
(define-public xfce4-mpc-plugin
(package
(name "xfce4-mpc-plugin")