summaryrefslogtreecommitdiff
path: root/gnu/packages/xfce.scm
diff options
context:
space:
mode:
authorIngo Ruhnke <grumbel@gmail.com>2019-10-03 21:38:42 +0200
committerDanny Milosavljevic <dannym@scratchpost.org>2019-10-04 14:31:06 +0200
commitdd249f1b8c371c08459f47a6b39c6dc477c5566b (patch)
treef472eda7725f852fe3d8866ef4b365d415213023 /gnu/packages/xfce.scm
parentde838a63383aa50f27bd311e5c04627da2e1922c (diff)
downloadguix-patches-dd249f1b8c371c08459f47a6b39c6dc477c5566b.tar
guix-patches-dd249f1b8c371c08459f47a6b39c6dc477c5566b.tar.gz
gnu: Add xfce4-mailwatch-plugin.
* gnu/packages/xfce.scm (xfce4-mailwatch-plugin): New variable. Signed-off-by: Danny Milosavljevic <dannym@scratchpost.org>
Diffstat (limited to 'gnu/packages/xfce.scm')
-rw-r--r--gnu/packages/xfce.scm38
1 files changed, 38 insertions, 0 deletions
diff --git a/gnu/packages/xfce.scm b/gnu/packages/xfce.scm
index 95c60630fc..2fcfab8a0c 100644
--- a/gnu/packages/xfce.scm
+++ b/gnu/packages/xfce.scm
@@ -1523,6 +1523,44 @@ button and a personalized tooltip.")
Caps, Scroll and Num Lock in Xfce panel.")
(license gpl2+)))
+(define-public xfce4-mailwatch-plugin
+ (package
+ (name "xfce4-mailwatch-plugin")
+ (version "1.2.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://archive.xfce.org/src/panel-plugins/"
+ "xfce4-mailwatch-plugin/"
+ (version-major+minor version)
+ "/xfce4-mailwatch-plugin-" version ".tar.bz2"))
+ (sha256
+ (base32
+ "1bfw3smwivr9mzdyq768biqrl4aq94zqi3xjzq6kqnd8561cqjk2"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("intltool" ,intltool)
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("gtk+-2" ,gtk+-2)
+ ("libxfce4ui" ,libxfce4ui)
+ ("exo" ,exo)
+ ("xfce4-panel" ,xfce4-panel)))
+ (home-page
+ "https://goodies.xfce.org/projects/panel-plugins/xfce4-mailwatch-plugin")
+ (synopsis "Mail watch plugin for the Xfce panel")
+ (description "The Xfce4 Mailwatch Plugin is a multi-protocol,
+multi-mailbox mail watcher. Currently, the protocols supported are:
+
+@itemize
+@item IMAP (SSL/TLS and cleartext, CRAM-MD5)
+@item POP3 (SSL/TLS and cleartext, CRAM-MD5)
+@item Mbox mail spool (local)
+@item Maildir mail spool (local)
+@item MH-Maildir mail spool (local)
+@item Google Mail (GMail) mailbox (remote) (requires gnutls)
+@end itemize")
+ (license gpl2)))
+
(define-public xfce4-mpc-plugin
(package
(name "xfce4-mpc-plugin")