summaryrefslogtreecommitdiff
path: root/gnu/packages/xfce.scm
diff options
context:
space:
mode:
authorIngo Ruhnke <grumbel@gmail.com>2019-10-03 21:38:41 +0200
committerDanny Milosavljevic <dannym@scratchpost.org>2019-10-04 14:30:58 +0200
commitde838a63383aa50f27bd311e5c04627da2e1922c (patch)
tree91699e04a3d550dab54241022b0c29ba5188c21c /gnu/packages/xfce.scm
parentb05edff0b2ba5f698e677bc36d80e33779312048 (diff)
downloadguix-patches-de838a63383aa50f27bd311e5c04627da2e1922c.tar
guix-patches-de838a63383aa50f27bd311e5c04627da2e1922c.tar.gz
gnu: Add xfce4-statusnotifier-plugin.
* gnu/packages/xfce.scm (xfce4-statusnotifier-plugin): New variable. Signed-off-by: Danny Milosavljevic <dannym@scratchpost.org>
Diffstat (limited to 'gnu/packages/xfce.scm')
-rw-r--r--gnu/packages/xfce.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/xfce.scm b/gnu/packages/xfce.scm
index 225ecbbc01..95c60630fc 100644
--- a/gnu/packages/xfce.scm
+++ b/gnu/packages/xfce.scm
@@ -1650,6 +1650,38 @@ directly to your browser, such that you can search through your
favorite search engine or bug tracker right from the Xfce panel.")
(license gpl2+)))
+(define-public xfce4-statusnotifier-plugin
+ (package
+ (name "xfce4-statusnotifier-plugin")
+ (version "0.2.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://archive.xfce.org/src/panel-plugins/"
+ "xfce4-statusnotifier-plugin/"
+ (version-major+minor version)
+ "/xfce4-statusnotifier-plugin-" version ".tar.bz2"))
+ (sha256
+ (base32
+ "154b0q9pmlbjh30vvx4c48msdfxp4pq8x4mbn71mk7pibk018hsj"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("intltool" ,intltool)
+ ("pkg-config" ,pkg-config)
+ ("glib:bin" ,glib "bin")))
+ (inputs
+ `(("libxfce4ui" ,libxfce4ui)
+ ("libdbusmenu" ,libdbusmenu)
+ ("xfce4-panel" ,xfce4-panel)))
+ (home-page
+ "https://goodies.xfce.org/projects/panel-plugins/xfce4-statusnotifier-plugin")
+ (synopsis "Xfce panel plugin for status notifier items")
+(description "This plugin provides a panel area for status
+notifier items (application indicators). Applications may use these
+items to display their status and interact with the user. This
+technology is a modern alternative to systray and follows the
+freedesktop.org specification.")
+ (license gpl2+)))
+
(define-public xfce4-stopwatch-plugin
(package
(name "xfce4-stopwatch-plugin")