summaryrefslogtreecommitdiff
path: root/gnu/packages/xfce.scm
diff options
context:
space:
mode:
authorIngo Ruhnke <grumbel@gmail.com>2019-10-03 21:38:39 +0200
committerDanny Milosavljevic <dannym@scratchpost.org>2019-10-04 14:30:41 +0200
commitd6056cc7fec16764c5212c8df9cc33fb201690aa (patch)
tree6a95f4afcb1149a623ef08aeb81a1943e00a0b94 /gnu/packages/xfce.scm
parente18bc5e0112c38fc67fa07b9bf34cbb5d1df4eca (diff)
downloadguix-patches-d6056cc7fec16764c5212c8df9cc33fb201690aa.tar
guix-patches-d6056cc7fec16764c5212c8df9cc33fb201690aa.tar.gz
gnu: Add xfce4-netload-plugin.
* gnu/packages/xfce.scm (xfce4-netload-plugin): New variable. Signed-off-by: Danny Milosavljevic <dannym@scratchpost.org>
Diffstat (limited to 'gnu/packages/xfce.scm')
-rw-r--r--gnu/packages/xfce.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/xfce.scm b/gnu/packages/xfce.scm
index 13836cf4a5..aaae28fa9a 100644
--- a/gnu/packages/xfce.scm
+++ b/gnu/packages/xfce.scm
@@ -1595,6 +1595,33 @@ mount it and vice versa. There is a warning in case a device can't be
mounted or when unmounting fails.")
(license gpl2+)))
+(define-public xfce4-netload-plugin
+ (package
+ (name "xfce4-netload-plugin")
+ (version "1.3.2")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://archive.xfce.org/src/panel-plugins/"
+ "xfce4-netload-plugin/"
+ (version-major+minor version)
+ "/xfce4-netload-plugin-" version ".tar.bz2"))
+ (sha256
+ (base32
+ "0p91875n6s8n88l7wb4w9prqly3wvkyilnr7zq0ppq71rwjh9r12"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("intltool" ,intltool)
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("libxfce4ui" ,libxfce4ui)
+ ("xfce4-panel" ,xfce4-panel)))
+ (home-page
+ "https://goodies.xfce.org/projects/panel-plugins/xfce4-netload-plugin")
+ (synopsis "Netload plugin for the Xfce Panel")
+ (description "This plugin displays the current load of the network
+interfaces of your choice in the panel.")
+ (license gpl2+)))
+
(define-public xfce4-smartbookmark-plugin
(package
(name "xfce4-smartbookmark-plugin")