summaryrefslogtreecommitdiff
path: root/gnu/packages/xfce.scm
diff options
context:
space:
mode:
authorIngo Ruhnke <grumbel@gmail.com>2019-10-03 21:38:43 +0200
committerDanny Milosavljevic <dannym@scratchpost.org>2019-10-04 14:31:20 +0200
commitcd0826d60bcfaba3233c2562776301ae0a65d978 (patch)
tree5111532e5d1439a0266cd1d1fe68ef0f61deaa63 /gnu/packages/xfce.scm
parentdd249f1b8c371c08459f47a6b39c6dc477c5566b (diff)
downloadguix-patches-cd0826d60bcfaba3233c2562776301ae0a65d978.tar
guix-patches-cd0826d60bcfaba3233c2562776301ae0a65d978.tar.gz
gnu: Add xfce4-equake-plugin.
* gnu/packages/xfce.scm (xfce4-equake-plugin): New variable. Signed-off-by: Danny Milosavljevic <dannym@scratchpost.org>
Diffstat (limited to 'gnu/packages/xfce.scm')
-rw-r--r--gnu/packages/xfce.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/xfce.scm b/gnu/packages/xfce.scm
index 2fcfab8a0c..2995d99a48 100644
--- a/gnu/packages/xfce.scm
+++ b/gnu/packages/xfce.scm
@@ -1290,6 +1290,35 @@ core or CPU.")
watch your every step.")
(license gpl2+)))
+(define-public xfce4-equake-plugin
+ (package
+ (name "xfce4-equake-plugin")
+ (version "1.3.8")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://archive.xfce.org/src/panel-plugins/"
+ "xfce4-equake-plugin/"
+ (version-major+minor version)
+ "/xfce4-equake-plugin-" version ".tar.bz2"))
+ (sha256
+ (base32
+ "09b9k0n5xm115k44x74w4ad0xqklilyfh0hglsps7zj97pd7a5a3"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("intltool" ,intltool)
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("gtk+-2" ,gtk+-2)
+ ("libxfce4ui" ,libxfce4ui)
+ ("xfce4-panel" ,xfce4-panel)))
+ (home-page
+ "https://goodies.xfce.org/projects/panel-plugins/xfce4-equake-plugin")
+ (synopsis "Earthquake monitor for the Xfce panel")
+ (description "Equake is a panel plugin for the XFCE desktop
+environment. Equake monitors earthquakes and will display an update
+each time a new earthquake occurs.")
+ (license gpl2+)))
+
(define-public xfce4-datetime-plugin
(package
(name "xfce4-datetime-plugin")