summaryrefslogtreecommitdiff
path: root/gnu/packages/xfce.scm
diff options
context:
space:
mode:
authorIngo Ruhnke <grumbel@gmail.com>2019-10-03 21:38:36 +0200
committerDanny Milosavljevic <dannym@scratchpost.org>2019-10-04 14:30:14 +0200
commit3b04836ebbda1bec6dbc108e922a67320e5db86c (patch)
treec6e0e66df28f155efd1a757c3f8e99de3884cc7d /gnu/packages/xfce.scm
parenta004609a1315969b9f78ac8ce104653758c2b6a3 (diff)
downloadguix-patches-3b04836ebbda1bec6dbc108e922a67320e5db86c.tar
guix-patches-3b04836ebbda1bec6dbc108e922a67320e5db86c.tar.gz
gnu: Add xfce4-time-out-plugin.
* gnu/packages/xfce.scm (xfce4-time-out-plugin): New variable. Signed-off-by: Danny Milosavljevic <dannym@scratchpost.org>
Diffstat (limited to 'gnu/packages/xfce.scm')
-rw-r--r--gnu/packages/xfce.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/xfce.scm b/gnu/packages/xfce.scm
index bf1e84366e..3708f9d2ed 100644
--- a/gnu/packages/xfce.scm
+++ b/gnu/packages/xfce.scm
@@ -1592,6 +1592,36 @@ environment. It displays the current CPU load, the memory in use, the
swap space and the system uptime in the Xfce4 panel.")
(license bsd-2)))
+(define-public xfce4-time-out-plugin
+ (package
+ (name "xfce4-time-out-plugin")
+ (version "1.0.3")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://archive.xfce.org/src/panel-plugins/"
+ "xfce4-time-out-plugin/"
+ (version-major+minor version)
+ "/xfce4-time-out-plugin-" version ".tar.bz2"))
+ (sha256
+ (base32
+ "0sqggsnkj40337v0c9vgakyh1zjzri6if38l85gcrnc39rlx973z"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("intltool" ,intltool)
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("gtk+-2" ,gtk+-2)
+ ("libxfce4ui" ,libxfce4ui)
+ ("xfce4-panel" ,xfce4-panel)))
+ (home-page
+ "https://goodies.xfce.org/projects/panel-plugins/xfce4-time-out-plugin")
+ (synopsis "Xfce panel plugin that encourages periodical breaks")
+ (description "This plugin encourages to take periodical
+breaks from the computer every X minutes. During breaks it locks your
+screen. It optionally allows you to postpone breaks for a certain
+time.")
+ (license gpl2+)))
+
(define-public xfce4-timer-plugin
(package
(name "xfce4-timer-plugin")