summaryrefslogtreecommitdiff
path: root/gnu/packages/vpn.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-03-06 11:13:12 +0100
committerMarius Bakke <mbakke@fastmail.com>2020-03-06 12:54:47 +0100
commit92594b2e0fdae039b9149bcf82b829294ab45fef (patch)
tree7832d6e2a56d118d3ec87eb25faec9c33c80ce00 /gnu/packages/vpn.scm
parentc67ee58c72e52261b54ed0dc2d4fd1d07be1e11d (diff)
downloadguix-patches-92594b2e0fdae039b9149bcf82b829294ab45fef.tar
guix-patches-92594b2e0fdae039b9149bcf82b829294ab45fef.tar.gz
gnu: vpnc-scripts: Tighten substitution regex.
* gnu/packages/vpn.scm (vpnc-scripts)[arguments]: Do not substitute file names starting with /bin to preserve /bin/sh shebangs.
Diffstat (limited to 'gnu/packages/vpn.scm')
-rw-r--r--gnu/packages/vpn.scm2
1 files changed, 1 insertions, 1 deletions
diff --git a/gnu/packages/vpn.scm b/gnu/packages/vpn.scm
index becc505b34..4899dbe3b7 100644
--- a/gnu/packages/vpn.scm
+++ b/gnu/packages/vpn.scm
@@ -152,7 +152,7 @@ Only \"Universal TUN/TAP device driver support\" is needed in the kernel.")
(for-each (lambda (script)
(substitute* script
(("^PATH=.*") "")
- (("(/usr|)/s?bin/") "")
+ (("/usr/s?bin/") "")
(("\\[ +-x +([^]]+) +\\]" _ command)
(string-append "command -v >/dev/null 2>&1 "
command))))