summaryrefslogtreecommitdiff
path: root/gnu/packages/vpn.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-04-23 22:00:41 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2019-04-24 01:47:48 +0200
commit28341601b323906d91821ed698537d261f2b0854 (patch)
treecfa6b4d360d23eea07490a50b1d63b7f78c9538d /gnu/packages/vpn.scm
parent14ccd8f8835d7ee08d94046fefd0e7e1fc86045d (diff)
downloadguix-patches-28341601b323906d91821ed698537d261f2b0854.tar
guix-patches-28341601b323906d91821ed698537d261f2b0854.tar.gz
gnu: xl2tpd: Don't use NAME in source URI.
* gnu/packages/vpn.scm (xl2tpd)[source]: Hard-code NAME.
Diffstat (limited to 'gnu/packages/vpn.scm')
-rw-r--r--gnu/packages/vpn.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/vpn.scm b/gnu/packages/vpn.scm
index b8ebeb509e..0c8e8e85b8 100644
--- a/gnu/packages/vpn.scm
+++ b/gnu/packages/vpn.scm
@@ -528,10 +528,10 @@ WireGuard support.")
(uri (git-reference
(url "https://github.com/xelerance/xl2tpd")
(commit (string-append "v" version))))
+ (file-name (git-file-name name version))
(sha256
(base32
- "1c2ahxz2zmmxwmk951d2qhijgz67zhwa1hn0r59fgz0y14w22myi"))
- (file-name (string-append "xl2tpd-" version "-checkout"))))
+ "1c2ahxz2zmmxwmk951d2qhijgz67zhwa1hn0r59fgz0y14w22myi"))))
(build-system gnu-build-system)
(arguments
`(#:make-flags (list (string-append "DESTDIR=" %output)