summaryrefslogtreecommitdiff
path: root/gnu/packages/vim.scm
diff options
context:
space:
mode:
authorFoo Chuan Wei <chuanwei.foo@hotmail.com>2021-10-12 15:06:31 +0000
committerEfraim Flashner <efraim@flashner.co.il>2021-10-25 11:02:40 +0300
commitbb524f43fb1722f4a3e948b7fae5b795077e86d1 (patch)
treed524f801866ad8d8fc50a68125f3d9e3743941a2 /gnu/packages/vim.scm
parentebd999c5d8153fc766bb064c88eac6be68935b90 (diff)
downloadguix-patches-bb524f43fb1722f4a3e948b7fae5b795077e86d1.tar
guix-patches-bb524f43fb1722f4a3e948b7fae5b795077e86d1.tar.gz
gnu: Add vim-gitgutter.
* gnu/packages/vim.scm (vim-gitgutter): New variable. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu/packages/vim.scm')
-rw-r--r--gnu/packages/vim.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/vim.scm b/gnu/packages/vim.scm
index 397bae5c3f..624ee38b63 100644
--- a/gnu/packages/vim.scm
+++ b/gnu/packages/vim.scm
@@ -1188,3 +1188,34 @@ anything).
whereby several completion methods are attempted one after another until a
result is returned.")
(license license:expat)))
+
+(define-public vim-gitgutter
+ (let ((commit "256702dd1432894b3607d3de6cd660863b331818")
+ (revision "1"))
+ (package
+ (name "vim-gitgutter")
+ (version (git-version "0.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/airblade/vim-gitgutter")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0zpa7cs59a8sq0k3frlf9flpf30jcn239yrpmv40r7nqvxzglbpl"))))
+ (build-system copy-build-system)
+ (arguments
+ '(#:install-plan
+ '(("autoload" "share/vim/vimfiles/")
+ ("doc" "share/vim/vimfiles/")
+ ("plugin" "share/vim/vimfiles/"))))
+ (synopsis "Vim plugin which shows a git diff in the sign column")
+ (description
+ "A Vim plugin which shows a git diff in the sign column. It shows which
+lines have been added, modified, or removed. You can also preview, stage, and
+undo individual hunks; and stage partial hunks. The plugin also provides a hunk
+text object. The signs are always up to date and the plugin never saves your
+buffer.")
+ (home-page "https://github.com/airblade/vim-gitgutter")
+ (license license:expat))))