summaryrefslogtreecommitdiff
path: root/gnu/packages/vim.scm
diff options
context:
space:
mode:
authorFoo Chuan Wei <chuanwei.foo@hotmail.com>2021-10-12 14:55:42 +0000
committerEfraim Flashner <efraim@flashner.co.il>2021-10-25 10:16:37 +0300
commitebd999c5d8153fc766bb064c88eac6be68935b90 (patch)
tree9d6778b48013a49f117121b6fe0ed7ad2991124c /gnu/packages/vim.scm
parentfb3b26b2ab73a2f0da4a3f3ae6e00ce098f9e610 (diff)
downloadguix-patches-ebd999c5d8153fc766bb064c88eac6be68935b90.tar
guix-patches-ebd999c5d8153fc766bb064c88eac6be68935b90.tar.gz
gnu: Add vim-mucomplete.
* gnu/packages/vim.scm (vim-mucomplete): New variable. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu/packages/vim.scm')
-rw-r--r--gnu/packages/vim.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/vim.scm b/gnu/packages/vim.scm
index 9d1a74319b..397bae5c3f 100644
--- a/gnu/packages/vim.scm
+++ b/gnu/packages/vim.scm
@@ -1161,3 +1161,30 @@ anything).
@item Mappings and usage conform to Vim's conventions.
@end itemize")
(license license:vim)))
+
+(define-public vim-mucomplete
+ (package
+ (name "vim-mucomplete")
+ (version "1.5.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/lifepillar/vim-mucomplete")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "054g80n09mmxxlh8xaic29bn8bgn3clvv732rymljdyvbj1mlhwd"))))
+ (build-system copy-build-system)
+ (arguments
+ '(#:install-plan
+ '(("autoload" "share/vim/vimfiles/")
+ ("doc" "share/vim/vimfiles/")
+ ("plugin" "share/vim/vimfiles/"))))
+ (home-page "https://github.com/lifepillar/vim-mucomplete")
+ (synopsis "MUcomplete is a minimalist autocompletion plugin for Vim")
+ (description
+ "MUcomplete is an implementation of chained (fallback) completion,
+whereby several completion methods are attempted one after another until a
+result is returned.")
+ (license license:expat)))