summaryrefslogtreecommitdiff
path: root/gnu/packages/vim.scm
diff options
context:
space:
mode:
authorFoo Chuan Wei <chuanwei.foo@hotmail.com>2021-10-12 15:48:10 +0000
committerEfraim Flashner <efraim@flashner.co.il>2021-10-31 15:20:37 +0200
commit9d9fa800b38a923bb458d5f4fd1124f3e4b93178 (patch)
tree0d798e89af871093ebc2a6ae9810202ce8426b86 /gnu/packages/vim.scm
parent508b072ab4b0327f16418b528a3cef2a58cfd27e (diff)
downloadguix-patches-9d9fa800b38a923bb458d5f4fd1124f3e4b93178.tar
guix-patches-9d9fa800b38a923bb458d5f4fd1124f3e4b93178.tar.gz
gnu: Add vim-tagbar.
* gnu/packages/vim.scm (vim-tagbar): New variable. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu/packages/vim.scm')
-rw-r--r--gnu/packages/vim.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/vim.scm b/gnu/packages/vim.scm
index 8db911b652..83227c91de 100644
--- a/gnu/packages/vim.scm
+++ b/gnu/packages/vim.scm
@@ -1253,3 +1253,33 @@ additions:
@item HTML entities: @code{&copy;}
@end itemize")
(license license:vim)))
+
+(define-public vim-tagbar
+ (package
+ (name "vim-tagbar")
+ (version "3.0.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/preservim/tagbar")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1fqfs8msmr6d4kpvxqp14sdjvp5fj52q5w5kz71myzcd4kqzmirp"))))
+ (build-system copy-build-system)
+ (arguments
+ '(#:install-plan
+ '(("autoload" "share/vim/vimfiles/")
+ ("doc" "share/vim/vimfiles/")
+ ("plugin" "share/vim/vimfiles/")
+ ("syntax" "share/vim/vimfiles/"))))
+ (home-page "https://github.com/preservim/tagbar")
+ (synopsis "Vim plugin that displays tags in a window, ordered by scope")
+ (description
+ "Tagbar is a Vim plugin that provides an easy way to browse the tags of
+the current file and get an overview of its structure. It does this by creating
+a sidebar that displays the ctags-generated tags of the current file, ordered
+by their scope. This means that for example methods in C++ are displayed under
+the class they are defined in.")
+ (license license:vim)))