summaryrefslogtreecommitdiff
path: root/gnu/packages/vim.scm
diff options
context:
space:
mode:
authorFoo Chuan Wei <chuanwei.foo@hotmail.com>2021-10-12 15:34:15 +0000
committerEfraim Flashner <efraim@flashner.co.il>2021-10-31 15:14:58 +0200
commit508b072ab4b0327f16418b528a3cef2a58cfd27e (patch)
treeedb619bb476e76f9c259f26245390b64461b6015 /gnu/packages/vim.scm
parentde81a58f79425dcab3d5e149657b97114be56325 (diff)
downloadguix-patches-508b072ab4b0327f16418b528a3cef2a58cfd27e.tar
guix-patches-508b072ab4b0327f16418b528a3cef2a58cfd27e.tar.gz
gnu: Add vim-characterize.
* gnu/packages/vim.scm (vim-characterize): New variable. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu/packages/vim.scm')
-rw-r--r--gnu/packages/vim.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/vim.scm b/gnu/packages/vim.scm
index 624ee38b63..8db911b652 100644
--- a/gnu/packages/vim.scm
+++ b/gnu/packages/vim.scm
@@ -1219,3 +1219,37 @@ text object. The signs are always up to date and the plugin never saves your
buffer.")
(home-page "https://github.com/airblade/vim-gitgutter")
(license license:expat))))
+
+(define-public vim-characterize
+ (package
+ (name "vim-characterize")
+ (version "1.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/tpope/vim-characterize")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0ppsbsd696ih40d9f76mdl9sd9y7p2pvm65qmvq4b2zhkv4xbpxz"))))
+ (build-system copy-build-system)
+ (arguments
+ '(#:install-plan
+ '(("autoload" "share/vim/vimfiles/")
+ ("doc" "share/vim/vimfiles/")
+ ("plugin" "share/vim/vimfiles/"))))
+ (home-page "https://github.com/tpope/vim-characterize")
+ (synopsis "Vim plugin for showing Unicode character metadata")
+ (description
+ "In Vim, pressing @code{ga} on a character reveals its representation in
+decimal, octal, and hex. Characterize.vim modernizes this with the following
+additions:
+@itemize
+@item Unicode character names: @code{U+00A9 COPYRIGHT SYMBOL}
+@item Vim digraphs (type after @code{<C-K>} to insert the character):
+@code{Co}, @code{cO}
+@item Emoji codes: @code{:copyright:}
+@item HTML entities: @code{&copy;}
+@end itemize")
+ (license license:vim)))