summaryrefslogtreecommitdiff
path: root/gnu/packages/vim.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2022-01-09 11:08:24 +0200
committerEfraim Flashner <efraim@flashner.co.il>2022-01-09 14:29:35 +0200
commit796bb42c11b9e8b06933ed6e331b5277bec2cbac (patch)
tree43cc69a4bad11f36399a1cf4bc17d107bb6ff3c9 /gnu/packages/vim.scm
parentb168c9f441d13718446fecee02205a7167cb43cc (diff)
downloadguix-patches-796bb42c11b9e8b06933ed6e331b5277bec2cbac.tar
guix-patches-796bb42c11b9e8b06933ed6e331b5277bec2cbac.tar.gz
gnu: xxd: Rewrite with gexps.
* gnu/packages/vim.scm (xxd)[arguments]: Rewrite with gexps.
Diffstat (limited to 'gnu/packages/vim.scm')
-rw-r--r--gnu/packages/vim.scm24
1 files changed, 12 insertions, 12 deletions
diff --git a/gnu/packages/vim.scm b/gnu/packages/vim.scm
index ed2e391c19..aaf3934ff2 100644
--- a/gnu/packages/vim.scm
+++ b/gnu/packages/vim.scm
@@ -31,6 +31,7 @@
(define-module (gnu packages vim)
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix packages)
+ #:use-module (guix gexp)
#:use-module (guix utils)
#:use-module (guix download)
#:use-module (guix git-download)
@@ -176,20 +177,19 @@ configuration files.")
(package (inherit vim)
(name "xxd")
(arguments
- `(#:make-flags (list ,(string-append "CC=" (cc-for-target)))
+ (list
+ #:make-flags #~(list (string-append "CC=" #$(cc-for-target)))
#:tests? #f ; there are none
#:phases
- (modify-phases %standard-phases
- (delete 'configure)
- (add-after 'unpack 'chdir
- (lambda _
- (chdir "src/xxd")
- #t))
- (replace 'install
- (lambda* (#:key outputs #:allow-other-keys)
- (let ((bin (string-append (assoc-ref outputs "out") "/bin")))
- (install-file "xxd" bin)
- #t))))))
+ #~(modify-phases %standard-phases
+ (delete 'configure)
+ (add-after 'unpack 'chdir
+ (lambda _
+ (chdir "src/xxd")))
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((bin (string-append (assoc-ref outputs "out") "/bin")))
+ (install-file "xxd" bin)))))))
(inputs `())
(native-inputs `())
(synopsis "Hexdump utility from vim")