summaryrefslogtreecommitdiff
path: root/gnu/packages/vim.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2022-01-09 10:58:54 +0200
committerEfraim Flashner <efraim@flashner.co.il>2022-01-09 14:29:35 +0200
commitb168c9f441d13718446fecee02205a7167cb43cc (patch)
tree90c95fbb14e9050cb30db4d0dcb3cb1236e00b87 /gnu/packages/vim.scm
parentba17cf41e8d6f8d6b5ade5058fd2c8d708e69d28 (diff)
downloadguix-patches-b168c9f441d13718446fecee02205a7167cb43cc.tar
guix-patches-b168c9f441d13718446fecee02205a7167cb43cc.tar.gz
gnu: vim: Remove unneeded make-flag.
Upstream reports this fixed with 8.2.3406. * gnu/packages/vim.scm (vim)[arguments]: Remove make-flags. (vim-full)[arguments]: Adjust accordingly.
Diffstat (limited to 'gnu/packages/vim.scm')
-rw-r--r--gnu/packages/vim.scm4
1 files changed, 1 insertions, 3 deletions
diff --git a/gnu/packages/vim.scm b/gnu/packages/vim.scm
index 911affed5d..ed2e391c19 100644
--- a/gnu/packages/vim.scm
+++ b/gnu/packages/vim.scm
@@ -89,8 +89,6 @@
(arguments
`(#:test-target "test"
#:parallel-tests? #f
- ;; Fix test_signals.vim. https://github.com/vim/vim/issues/7402
- #:make-flags (list "CFLAGS=-D_REENTRANT")
#:phases
(modify-phases %standard-phases
(add-after 'configure 'patch-absolute-paths
@@ -225,7 +223,7 @@ with the editor vim.")))
((#:make-flags flags)
`(append
(list "LDFLAGS=-lexpat")
- (delete "CFLAGS=-D_REENTRANT" ,flags)))
+ ,flags))
((#:phases phases)
`(modify-phases ,phases
(add-before 'check 'start-xserver