summaryrefslogtreecommitdiff
path: root/gnu/packages/video.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2020-06-22 16:58:54 +0200
committerMarius Bakke <marius@gnu.org>2020-06-22 17:16:38 +0200
commit3d5a217d5e71821465a8653945e494205b7d511b (patch)
tree1a6594acf9e5300f63be1735a777c8b01aaddf81 /gnu/packages/video.scm
parent402d03751c03e509b9aee1f26eed40cae81eebba (diff)
downloadguix-patches-3d5a217d5e71821465a8653945e494205b7d511b.tar
guix-patches-3d5a217d5e71821465a8653945e494205b7d511b.tar.gz
gnu: ungoogled-chromium: Build with ffmpeg@4.2.
Fixes <https://bugs.gnu.org/41987>. Reported by Jonathan Brielmaier <jonathan.brielmaier@web.de>. * gnu/packages/video.scm (ffmpeg-4.2): New public variable. * gnu/packages/chromium.scm (ungoogled-chromium)[inputs]: Change from FFMPEG to FFMPEG-4.2.
Diffstat (limited to 'gnu/packages/video.scm')
-rw-r--r--gnu/packages/video.scm18
1 files changed, 18 insertions, 0 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index eabd657798..058e466069 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -1126,6 +1126,24 @@ convert and stream audio and video. It includes the libavcodec
audio/video codec library.")
(license license:gpl2+)))
+;; ungoogled-chromium crashes with ffmpeg 4.3, so stick with this version for
+;; now. See <https://issues.guix.gnu.org/41987>.
+(define-public ffmpeg-4.2
+ (package
+ (inherit ffmpeg)
+ (version "4.2.3")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://ffmpeg.org/releases/ffmpeg-"
+ version ".tar.xz"))
+ (sha256
+ (base32
+ "0cddkb5sma9dzy8i59sfls19rhjlq40zn9mh3x666dqkxl5ckxlx"))))
+ (arguments
+ (substitute-keyword-arguments (package-arguments ffmpeg)
+ ((#:configure-flags flags)
+ `(delete "--enable-librav1e" ,flags))))))
+
(define-public ffmpeg-3.4
(package
(inherit ffmpeg)