summaryrefslogtreecommitdiff
path: root/gnu/packages/video.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2020-06-22 16:57:13 +0200
committerMarius Bakke <marius@gnu.org>2020-06-22 17:16:38 +0200
commit402d03751c03e509b9aee1f26eed40cae81eebba (patch)
tree9cad1f91425b23aed2a2bd9aea8cbcd5b89ec6f4 /gnu/packages/video.scm
parent1cb9effc3e875ec7bae31bb06069d16ac89f7e1d (diff)
downloadguix-patches-402d03751c03e509b9aee1f26eed40cae81eebba.tar
guix-patches-402d03751c03e509b9aee1f26eed40cae81eebba.tar.gz
gnu: ffmpeg: Enable rav1e on x86_64 only.
Fixes <https://bugs.gnu.org/41993>. Reported by Kurt I <gitlabcanada@runbox.com>. * gnu/packages/video.scm (ffmpeg)[inputs]: Conditionally add RAV1E. [arguments]: Adjust #:configure-flags accordingly.
Diffstat (limited to 'gnu/packages/video.scm')
-rw-r--r--gnu/packages/video.scm12
1 files changed, 10 insertions, 2 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 4e521473fe..eabd657798 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -971,7 +971,12 @@ operate properly.")
("mesa" ,mesa)
("openal" ,openal)
("pulseaudio" ,pulseaudio)
- ("rav1e" ,rav1e)
+ ;; XXX: rav1e depends on rust, which currently only works on x86_64.
+ ;; See also the related configure flag when changing this.
+ ,@(if (string-prefix? "x86_64" (or (%current-target-system)
+ (%current-system)))
+ `(("rav1e" ,rav1e))
+ '())
("sdl" ,sdl2)
("soxr" ,soxr)
("speex" ,speex)
@@ -1053,7 +1058,10 @@ operate properly.")
"--enable-libmp3lame"
"--enable-libopus"
"--enable-libpulse"
- "--enable-librav1e"
+ ,@(if (string-prefix? "x86_64" (or (%current-target-system)
+ (%current-system)))
+ '("--enable-librav1e")
+ '())
"--enable-libsoxr"
"--enable-libspeex"
"--enable-libtheora"