summaryrefslogtreecommitdiff
path: root/gnu/packages/version-control.scm
diff options
context:
space:
mode:
authorAshish SHUKLA <ashish.is@lostca.se>2024-05-21 23:59:46 +0000
committerGuix Patches Tester <>2024-05-22 02:11:50 +0200
commit59847f0447010a292cfe6e1b7890d82bec64eb33 (patch)
tree94f9f8f7a6d85718ee47a7bf0822bc723406d0ed /gnu/packages/version-control.scm
parentdd03be186adb64bdb77265dfd0ad53fe50ec016e (diff)
downloadguix-patches-issue-70389.tar
guix-patches-issue-70389.tar.gz
gnu: fossil: Update to 2.24.issue-70389
* gnu/packages/version-control.scm (fossil): Update to 2.24. [sources]: Switch to a simpler tarball URL. Add patches from upstream to fix unit-tests. [inputs]: Switch to sqlite-next as fossil needs bleeding edge sqlite. Change-Id: Id0cac2634282a0a141e2b17cb423c25e8aacee38
Diffstat (limited to 'gnu/packages/version-control.scm')
-rw-r--r--gnu/packages/version-control.scm30
1 files changed, 23 insertions, 7 deletions
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index c01eb9decd..d985c531d0 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -3068,19 +3068,35 @@ by rclone usable with git-annex.")
(license license:gpl3+)))
(define-public fossil
+ (define (fossil-patch name from to hash)
+ (origin (method url-fetch)
+ (uri (string-append "https://fossil-scm.org/home/vpatch?from=" from
+ "&to=" to))
+ (sha256 (base32 hash))
+ (file-name name)))
(package
(name "fossil")
- (version "2.20")
+ (version "2.24")
(source
(origin
(method url-fetch)
(uri (string-append
- "https://www.fossil-scm.org/home/tarball/"
- "210e89a0597f225f49722b096cf5563bf193e920e02a9bd38503a906deacd416"
- "/fossil-src-" version ".tar.gz"))
- ;; XXX: Currently the above hash must be manually updated.
+ "https://fossil-scm.org/home/tarball/version-" version "/fossil-" version ".tar.gz"))
(sha256
- (base32 "08g7img88n2nwcdkpzmg4aqbp2iy40nllgas53502dspm97ym4h8"))
+ (base32 "0k1gjvxbvvs98yspnf7nj6rb0c7yf60savq7jywbkgimd0bkrkcm"))
+ (patch-flags '("-p0"))
+ (patches `(,(fossil-patch "fossil-disable-tests.patch"
+ "8be0372c10510437"
+ "5ad708085a90365f"
+ "1b4svsrz7cr1zi6qfpavj3ddm6dr0966jbgkbvgjz79ljqmpiasf")
+ ,(fossil-patch "fossil-fix-json-test.patch"
+ "fb4e90b662803e47"
+ "17c01c549e73c6b8"
+ "12gjzyxs22g9grv7qbgp9jg133bgcsj74621s05fk82j3fc7z59g")
+ ,(fossil-patch "fossil-comment-utf-tests.patch"
+ "5ad708085a90365f"
+ "fb4e90b662803e47"
+ "05h2mb6g0840yq74x1cdj95jmqb95i75h6g5v0rzqdc994b96cd4")))
(modules '((guix build utils)))
(snippet
'(delete-file-recursively "compat"))))
@@ -3090,7 +3106,7 @@ by rclone usable with git-annex.")
which ;for tests only
ed)) ;ditto
(inputs
- (list openssl zlib sqlite))
+ (list openssl zlib sqlite-next))
(arguments
`(#:configure-flags (list "--with-openssl=auto"
"--disable-internal-sqlite")