summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAshish SHUKLA <ashish.is@lostca.se>2024-04-14 23:54:50 +0000
committerGuix Patches Tester <>2024-04-17 14:03:17 +0200
commitfa45ee3b30fd6c769244e29979cece79ae665edf (patch)
treeeebf260931b77fe30431adb26c01c5b6391a95ba
parentb47ae1ecc43baaf726701ab2d2f810ecfaa75428 (diff)
downloadguix-patches-issue-70389.tar
guix-patches-issue-70389.tar.gz
gnu: fossil: update to 2.23issue-70389
* gnu/packages/version-control.scm (fossil): Update to 2.23. Signed-off-by: Ashish SHUKLA <ashish.is@lostca.se> Change-Id: I1794e75cedc4a9bd878850e25686674cecd360e0
-rw-r--r--gnu/packages/version-control.scm8
1 files changed, 4 insertions, 4 deletions
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index 0c7c496c82..8f5e41acc1 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -3070,17 +3070,17 @@ by rclone usable with git-annex.")
(define-public fossil
(package
(name "fossil")
- (version "2.20")
+ (version "2.23")
(source
(origin
(method url-fetch)
(uri (string-append
"https://www.fossil-scm.org/home/tarball/"
- "210e89a0597f225f49722b096cf5563bf193e920e02a9bd38503a906deacd416"
+ "47362306a7dd7c6fc3cab77cebe5d25469b0a9448479d9718eb5c49c8337b29"
"/fossil-src-" version ".tar.gz"))
;; XXX: Currently the above hash must be manually updated.
(sha256
- (base32 "08g7img88n2nwcdkpzmg4aqbp2iy40nllgas53502dspm97ym4h8"))
+ (base32 "1r1kabvmlhc0qgyq8g9zhq8i0123x9dba9b71j4xc71k14kfqjm9"))
(modules '((guix build utils)))
(snippet
'(delete-file-recursively "compat"))))
@@ -3090,7 +3090,7 @@ by rclone usable with git-annex.")
which ;for tests only
ed)) ;ditto
(inputs
- (list openssl zlib sqlite))
+ (list openssl zlib sqlite-next))
(arguments
`(#:configure-flags (list "--with-openssl=auto"
"--disable-internal-sqlite")