summaryrefslogtreecommitdiff
path: root/gnu/packages/upnp.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2016-11-24 18:48:15 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2016-11-25 02:21:51 +0100
commit5af82630feb1c6b65edc3dd14bf05d025b77b209 (patch)
tree2c2251e94bef948edfb5b59f46fd9b536de968b0 /gnu/packages/upnp.scm
parentcdbdaf7b6b2c232bca5f2e84af3dca097a3f5ce6 (diff)
downloadguix-patches-5af82630feb1c6b65edc3dd14bf05d025b77b209.tar
guix-patches-5af82630feb1c6b65edc3dd14bf05d025b77b209.tar.gz
gnu: miniupnpc: Use the correct ‘upnpc’ in ‘external-ip’.
* gnu/packages/upnp.scm (miniupnpc)[arguments]: Add ‘qualify-paths’ phase.
Diffstat (limited to 'gnu/packages/upnp.scm')
-rw-r--r--gnu/packages/upnp.scm8
1 files changed, 7 insertions, 1 deletions
diff --git a/gnu/packages/upnp.scm b/gnu/packages/upnp.scm
index 35bacc75f6..ffb671bf4c 100644
--- a/gnu/packages/upnp.scm
+++ b/gnu/packages/upnp.scm
@@ -1,5 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2014 Sree Harsha Totakura <sreeharsha@totakura.in>
+;;; Copyright © 2016 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -55,7 +56,12 @@
(assoc-ref %outputs "out") "/lib"))
#:phases
(modify-phases %standard-phases
- (delete 'configure))))
+ (delete 'configure)
+ (add-before 'install 'qualify-paths
+ (lambda* (#:key outputs #:allow-other-keys)
+ (substitute* "external-ip.sh"
+ (("upnpc")
+ (string-append (assoc-ref outputs "out") "/bin/upnpc"))))))))
(home-page "http://miniupnp.free.fr/")
(synopsis "Library implementing the client side UPnP protocol")
(description