summaryrefslogtreecommitdiff
path: root/gnu/packages/tryton.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2021-08-27 15:09:46 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2021-09-21 21:00:33 +0200
commite18b43ae38b90cb63be228886289eda24da00965 (patch)
tree7a9a894fe5b02872513a953eb3464f176a409b77 /gnu/packages/tryton.scm
parentaefbc05c37a0726e79d82d99d62a6e9bafab2a06 (diff)
downloadguix-patches-e18b43ae38b90cb63be228886289eda24da00965.tar
guix-patches-e18b43ae38b90cb63be228886289eda24da00965.tar.gz
gnu: Add trytond-sale-supply.
* gnu/packages/tryton.scm (trytond-sale-supply): New variable.
Diffstat (limited to 'gnu/packages/tryton.scm')
-rw-r--r--gnu/packages/tryton.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
index cce5be44e3..4117c925b5 100644
--- a/gnu/packages/tryton.scm
+++ b/gnu/packages/tryton.scm
@@ -3585,6 +3585,35 @@ services and recurrence rule models.")
notion of asset to the sale subscription module.")
(license license:gpl3+)))
+(define-public trytond-sale-supply
+ (package
+ (name "trytond-sale-supply")
+ (version "6.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "trytond_sale_supply" version))
+ (sha256
+ (base32 "0lk4pj2fr1q603wnia96i7fzym8pncpvy0hg41q4dkr380nm3qzs"))))
+ (build-system python-build-system)
+ (arguments (tryton-arguments "sale_supply"))
+ (native-inputs `(,@%standard-trytond-native-inputs))
+ (propagated-inputs
+ `(("trytond" ,trytond)
+ ("trytond-purchase" ,trytond-purchase)
+ ("trytond-purchase-request" ,trytond-purchase-request)
+ ("trytond-sale" ,trytond-sale)
+ ("trytond-stock" ,trytond-stock)))
+ (home-page "https://docs.tryton.org/projects/modules-sale-supply")
+ (synopsis "Tryton module for sale supply")
+ (description "The @emph{Sale Supply} Tryton module adds a \"supply on sale
+option\" to purchasable products. If checked, it will generate a purchase
+request for each sale line of this product regardless of the stock levels.
+Once the purchased products are received they are assigned on the customer
+shipments. If the purchase is cancelled the sale goes back to the default
+supply method.")
+ (license license:gpl3+)))
+
(define-public trytond-stock
(package
(name "trytond-stock")