summaryrefslogtreecommitdiff
path: root/gnu/packages/tryton.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2021-08-27 15:09:46 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2021-09-21 21:00:33 +0200
commitaefbc05c37a0726e79d82d99d62a6e9bafab2a06 (patch)
treedfc07ee77a66274965bccc4d5abbaa5f4adc52f4 /gnu/packages/tryton.scm
parent77a3fb1d768b676cf390f80ee7a50a0e1a2e858e (diff)
downloadguix-patches-aefbc05c37a0726e79d82d99d62a6e9bafab2a06.tar
guix-patches-aefbc05c37a0726e79d82d99d62a6e9bafab2a06.tar.gz
gnu: Add trytond-sale-subscription-asset.
* gnu/packages/tryton.scm (trytond-sale-subscription-asset): New variable.
Diffstat (limited to 'gnu/packages/tryton.scm')
-rw-r--r--gnu/packages/tryton.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
index 0dd0a6463d..cce5be44e3 100644
--- a/gnu/packages/tryton.scm
+++ b/gnu/packages/tryton.scm
@@ -3561,6 +3561,30 @@ stock forecasts.")
services and recurrence rule models.")
(license license:gpl3+)))
+(define-public trytond-sale-subscription-asset
+ (package
+ (name "trytond-sale-subscription-asset")
+ (version "6.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "trytond_sale_subscription_asset" version))
+ (sha256
+ (base32 "1j160sqfvzqv0ah85w2bsc4fixrxhzjq0lbin2bgasmdm3yqfqdj"))))
+ (build-system python-build-system)
+ (arguments (tryton-arguments "sale_subscription_asset"))
+ (native-inputs `(,@%standard-trytond-native-inputs))
+ (propagated-inputs
+ `(("trytond" ,trytond)
+ ("trytond-sale-subscription" ,trytond-sale-subscription)
+ ("trytond-stock-lot" ,trytond-stock-lot)))
+ (home-page
+ "https://docs.tryton.org/projects/modules-sale-subscription-asset")
+ (synopsis "Tryton module to handle asset in the sale subscriptions")
+ (description "The @emph{Sale Subscription Asset} Tryton module adds the
+notion of asset to the sale subscription module.")
+ (license license:gpl3+)))
+
(define-public trytond-stock
(package
(name "trytond-stock")