summaryrefslogtreecommitdiff
path: root/gnu/packages/tryton.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2021-08-27 15:09:59 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2021-09-21 21:00:35 +0200
commitdf549fd893162a6bf3a32309f26d7c710895293c (patch)
tree907ab2144008d4dec9f3910a967c4297861461fe /gnu/packages/tryton.scm
parent639004caf2d5d6e6ea64a39808a45bd9ff52b3d5 (diff)
downloadguix-patches-df549fd893162a6bf3a32309f26d7c710895293c.tar
guix-patches-df549fd893162a6bf3a32309f26d7c710895293c.tar.gz
gnu: Add trytond-web-shop-vue-storefront-stripe.
* gnu/packages/tryton.scm (trytond-web-shop-vue-storefront-stripe): New variable.
Diffstat (limited to 'gnu/packages/tryton.scm')
-rw-r--r--gnu/packages/tryton.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
index 8fd5f4581f..5a74a5f4e3 100644
--- a/gnu/packages/tryton.scm
+++ b/gnu/packages/tryton.scm
@@ -4442,3 +4442,29 @@ configuration of an online web shop.")
(description "This Tryton module provides the back-end to integrate with
Vue Storefront 1.x.")
(license license:gpl3+)))
+
+(define-public trytond-web-shop-vue-storefront-stripe
+ (package
+ (name "trytond-web-shop-vue-storefront-stripe")
+ (version "6.0.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "trytond_web_shop_vue_storefront_stripe" version))
+ (sha256
+ (base32 "0j4yv9q0f39bkyqlcn7kpnlqi9wc4qfjs8zic69za6xw2c86zgzm"))))
+ (build-system python-build-system)
+ (arguments (tryton-arguments "web_shop_vue_storefront_stripe"))
+ (native-inputs `(,@%standard-trytond-native-inputs))
+ (propagated-inputs
+ `(("trytond" ,trytond)
+ ("trytond-account-payment-stripe" ,trytond-account-payment-stripe)
+ ("trytond-sale-payment" ,trytond-sale-payment)
+ ("trytond-web-shop" ,trytond-web-shop)
+ ("trytond-web-shop-vue-storefront" ,trytond-web-shop-vue-storefront)))
+ (home-page
+ "https://docs.tryton.org/projects/modules-web-shop-vue-storefront-stripe")
+ (synopsis "Tryton module to support Stripe payment with Vue Storefront")
+ (description "The @emph{Web Shop Vue Storefront Stripe} Tryton module
+provides support of Stripe payment for Vue Storefront integration.")
+ (license license:gpl3+)))