summaryrefslogtreecommitdiff
path: root/gnu/packages/tryton.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2021-08-27 15:09:58 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2021-09-21 21:00:35 +0200
commit639004caf2d5d6e6ea64a39808a45bd9ff52b3d5 (patch)
tree65bc2ea25b33008969cec0cd45e761f2ab01aa4d /gnu/packages/tryton.scm
parentdc11d823566b1d8001303c0c93378319a6fb06ed (diff)
downloadguix-patches-639004caf2d5d6e6ea64a39808a45bd9ff52b3d5.tar
guix-patches-639004caf2d5d6e6ea64a39808a45bd9ff52b3d5.tar.gz
gnu: Add trytond-web-shop-vue-storefront.
* gnu/packages/tryton.scm (trytond-web-shop-vue-storefront): New variable.
Diffstat (limited to 'gnu/packages/tryton.scm')
-rw-r--r--gnu/packages/tryton.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
index eaa0c3258b..8fd5f4581f 100644
--- a/gnu/packages/tryton.scm
+++ b/gnu/packages/tryton.scm
@@ -4408,3 +4408,37 @@ user for a period of time only.")
(description "The @emph{Web Shop} Tryton module facilitates storing
configuration of an online web shop.")
(license license:gpl3+)))
+
+(define-public trytond-web-shop-vue-storefront
+ (package
+ (name "trytond-web-shop-vue-storefront")
+ (version "6.0.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "trytond_web_shop_vue_storefront" version))
+ (sha256
+ (base32 "0hccvk5i2qrczvbm66mnp8vcgr9zbnwqmbqmavqlkk7r7bqa1gch"))))
+ (build-system python-build-system)
+ (arguments (tryton-arguments "web_shop_vue_storefront"))
+ (native-inputs
+ `(,@%standard-trytond-native-inputs
+ ("trytond-carrier" ,trytond-carrier)
+ ("trytond-product-attribute" ,trytond-product-attribute)
+ ("trytond-sale-promotion-coupon" ,trytond-sale-promotion-coupon)
+ ("trytond-sale-shipment-cost" ,trytond-sale-shipment-cost)))
+ (propagated-inputs
+ `(("python-elasticsearch" ,python-elasticsearch)
+ ("python-stdnum" ,python-stdnum)
+ ("trytond" ,trytond)
+ ("trytond-party" ,trytond-party)
+ ("trytond-product" ,trytond-product)
+ ("trytond-sale" ,trytond-sale)
+ ("trytond-web-shop" ,trytond-web-shop)
+ ("trytond-web-user" ,trytond-web-user)))
+ (home-page
+ "https://docs.tryton.org/projects/modules-web-shop-vue-storefront")
+ (synopsis "Tryton module to integrate with Vue Storefront")
+ (description "This Tryton module provides the back-end to integrate with
+Vue Storefront 1.x.")
+ (license license:gpl3+)))