summaryrefslogtreecommitdiff
path: root/gnu/packages/tryton.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2021-08-27 15:09:59 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2021-09-21 21:00:35 +0200
commitb187cba93570b91133664cafddcf3c8fb67f4ae3 (patch)
tree79a9f0c18ea6e4a7eb5f42b601cd55b866b327f0 /gnu/packages/tryton.scm
parentdf549fd893162a6bf3a32309f26d7c710895293c (diff)
downloadguix-patches-b187cba93570b91133664cafddcf3c8fb67f4ae3.tar
guix-patches-b187cba93570b91133664cafddcf3c8fb67f4ae3.tar.gz
gnu: Add trytond-web-shortener.
* gnu/packages/tryton.scm (trytond-web-shortener): New variable.
Diffstat (limited to 'gnu/packages/tryton.scm')
-rw-r--r--gnu/packages/tryton.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
index 5a74a5f4e3..c86a27e05b 100644
--- a/gnu/packages/tryton.scm
+++ b/gnu/packages/tryton.scm
@@ -4468,3 +4468,25 @@ Vue Storefront 1.x.")
(description "The @emph{Web Shop Vue Storefront Stripe} Tryton module
provides support of Stripe payment for Vue Storefront integration.")
(license license:gpl3+)))
+
+(define-public trytond-web-shortener
+ (package
+ (name "trytond-web-shortener")
+ (version "6.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "trytond_web_shortener" version))
+ (sha256
+ (base32 "0vxwnsy7xzxawn7fmm6ykdrhih6ahrwwx6fzd6kz7qbwh4nmqcpk"))))
+ (build-system python-build-system)
+ (arguments (tryton-arguments "web_shortener"))
+ (native-inputs `(,@%standard-trytond-native-inputs))
+ (propagated-inputs
+ `(("trytond" ,trytond)))
+ (home-page "https://docs.tryton.org/projects/modules-web-shortener")
+ (synopsis "Tryton module to plug a URL to an action")
+ (description "The @emph{Web Shortener} Tryton module allows URLs to be
+shortened. It also counts the number of times the URL is accessed and
+optionally triggers action.")
+ (license license:gpl3+)))