summaryrefslogtreecommitdiff
path: root/gnu/packages/tryton.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2021-08-27 15:09:29 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2021-09-21 21:00:30 +0200
commit65c6dba800dd41e23ad36cde4b11bc4d7ce0f10f (patch)
tree768888e81eb18084e555238d61f337160ba1cf7f /gnu/packages/tryton.scm
parent4c3a9c471f1d22391e893d515bb0a3d35a6a1e6c (diff)
downloadguix-patches-65c6dba800dd41e23ad36cde4b11bc4d7ce0f10f.tar
guix-patches-65c6dba800dd41e23ad36cde4b11bc4d7ce0f10f.tar.gz
gnu: Add trytond-production-routing.
* gnu/packages/tryton.scm (trytond-production-routing): New variable.
Diffstat (limited to 'gnu/packages/tryton.scm')
-rw-r--r--gnu/packages/tryton.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
index 3936c1c5e9..e787951718 100644
--- a/gnu/packages/tryton.scm
+++ b/gnu/packages/tryton.scm
@@ -2450,6 +2450,30 @@ set to @code{waiting}, a purchase order is created and its cost is added to
the production.")
(license license:gpl3+)))
+(define-public trytond-production-routing
+ (package
+ (name "trytond-production-routing")
+ (version "6.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "trytond_production_routing" version))
+ (sha256
+ (base32 "0qypqsf36lf02wrbv7pwhg2vv7004g7c6vxd1z2aiwj58g8q7894"))))
+ (build-system python-build-system)
+ (arguments (tryton-arguments "production_routing"))
+ (native-inputs
+ `(,@%standard-trytond-native-inputs
+ ("trytond-stock-supply-production" ,trytond-stock-supply-production)))
+ (propagated-inputs
+ `(("trytond" ,trytond)
+ ("trytond-production" ,trytond-production)))
+ (home-page "https://docs.tryton.org/projects/modules-production-routing")
+ (synopsis "Tryton module for production routing")
+ (description "The @emph{Production Routing} Tryton module defines the
+routings for production: Routing, Step and Operation.")
+ (license license:gpl3+)))
+
(define-public trytond-purchase
(package
(name "trytond-purchase")