summaryrefslogtreecommitdiff
path: root/gnu/packages/tryton.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2021-08-27 15:09:29 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2021-09-21 21:00:30 +0200
commit4c3a9c471f1d22391e893d515bb0a3d35a6a1e6c (patch)
tree149f690d51e77e18296a7751db45bc73d59c4ac2 /gnu/packages/tryton.scm
parenta53c6040e4cf15f161a010d39d72d05ed341df9d (diff)
downloadguix-patches-4c3a9c471f1d22391e893d515bb0a3d35a6a1e6c.tar
guix-patches-4c3a9c471f1d22391e893d515bb0a3d35a6a1e6c.tar.gz
gnu: Add trytond-production-outsourcing.
* gnu/packages/tryton.scm (trytond-production-outsourcing): New variable.
Diffstat (limited to 'gnu/packages/tryton.scm')
-rw-r--r--gnu/packages/tryton.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
index 382f814ed1..3936c1c5e9 100644
--- a/gnu/packages/tryton.scm
+++ b/gnu/packages/tryton.scm
@@ -2422,6 +2422,34 @@ which contains the unit price computed by the parent price list.")
for production management: Bill of material and production order.")
(license license:gpl3+)))
+(define-public trytond-production-outsourcing
+ (package
+ (name "trytond-production-outsourcing")
+ (version "6.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "trytond_production_outsourcing" version))
+ (sha256
+ (base32 "08pp80d4jfw7qmhvds60i63pb2nad489xwkf2ybbzdkrzhcgrrjk"))))
+ (build-system python-build-system)
+ (arguments (tryton-arguments "production_outsourcing"))
+ (native-inputs `(,@%standard-trytond-native-inputs))
+ (propagated-inputs
+ `(("trytond" ,trytond)
+ ("trytond-product" ,trytond-product)
+ ("trytond-production" ,trytond-production)
+ ("trytond-production-routing" ,trytond-production-routing)
+ ("trytond-purchase" ,trytond-purchase)))
+ (home-page
+ "https://docs.tryton.org/projects/modules-production-outsourcing")
+ (synopsis "Tryton module to outsource production")
+ (description "The @emph{Production Outsourcing} Tryton module allows to
+outsource production order per routing. When such outsourced production is
+set to @code{waiting}, a purchase order is created and its cost is added to
+the production.")
+ (license license:gpl3+)))
+
(define-public trytond-purchase
(package
(name "trytond-purchase")