summaryrefslogtreecommitdiff
path: root/gnu/packages/tryton.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2021-08-27 15:09:59 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2021-09-21 21:00:35 +0200
commit5966d48d1c9e48b7098845193469f5b5fe07d540 (patch)
tree953f82c4947b98f927f567b147c08df190e400d9 /gnu/packages/tryton.scm
parentb187cba93570b91133664cafddcf3c8fb67f4ae3 (diff)
downloadguix-patches-5966d48d1c9e48b7098845193469f5b5fe07d540.tar
guix-patches-5966d48d1c9e48b7098845193469f5b5fe07d540.tar.gz
gnu: Add trytond-web-user.
* gnu/packages/tryton.scm (trytond-web-user): New variable.
Diffstat (limited to 'gnu/packages/tryton.scm')
-rw-r--r--gnu/packages/tryton.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
index c86a27e05b..37f0f9adf2 100644
--- a/gnu/packages/tryton.scm
+++ b/gnu/packages/tryton.scm
@@ -4490,3 +4490,25 @@ provides support of Stripe payment for Vue Storefront integration.")
shortened. It also counts the number of times the URL is accessed and
optionally triggers action.")
(license license:gpl3+)))
+
+(define-public trytond-web-user
+ (package
+ (name "trytond-web-user")
+ (version "6.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "trytond_web_user" version))
+ (sha256
+ (base32 "1k07d1kcfm2hwwqcyy8k5mjbhhgrnji0hadn487zsx1zp50r6rds"))))
+ (build-system python-build-system)
+ (arguments (tryton-arguments "web_user"))
+ (native-inputs `(,@%standard-trytond-native-inputs))
+ (propagated-inputs
+ `(("trytond" ,trytond)
+ ("trytond-party" ,trytond-party)))
+ (home-page "https://docs.tryton.org/projects/modules-web-user")
+ (synopsis "Tryton module to manage Web users")
+ (description "The @emph{Web User} Tryton module provides facilities to
+manage external user accessing from the web.")
+ (license license:gpl3+)))