summaryrefslogtreecommitdiff
path: root/gnu/packages/tryton.scm
diff options
context:
space:
mode:
authorAdriano Peluso <catonano@gmail.com>2017-05-20 08:32:08 +0200
committerArun Isaac <arunisaac@systemreboot.net>2017-05-27 18:41:13 +0530
commit16855482fd0bcc2460028c701498d35d248a6269 (patch)
treeae86ad935970ae3d6e3e8df26ec5350c18055825 /gnu/packages/tryton.scm
parent48174fb9aacd2a9c52edf769094481bc9ba03003 (diff)
downloadguix-patches-16855482fd0bcc2460028c701498d35d248a6269.tar
guix-patches-16855482fd0bcc2460028c701498d35d248a6269.tar.gz
gnu: Add tryton.
* gnu/packages/tryton.scm (tryton): New variable. Signed-off-by: Arun Isaac <arunisaac@systemreboot.net>
Diffstat (limited to 'gnu/packages/tryton.scm')
-rw-r--r--gnu/packages/tryton.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
index 590bd54382..c9e9e50f84 100644
--- a/gnu/packages/tryton.scm
+++ b/gnu/packages/tryton.scm
@@ -19,6 +19,7 @@
(define-module (gnu packages tryton)
#:use-module ((guix licenses) #:prefix license:)
#:use-module (gnu packages)
+ #:use-module (gnu packages gtk)
#:use-module (gnu packages python)
#:use-module (guix packages)
#:use-module (guix download)
@@ -65,3 +66,28 @@ application platform using PostgreSQL as its main database engine. It is the
core base of a complete business solution providing modularity, scalability
and security.")
(license license:gpl3+)))
+
+(define-public tryton
+ (package
+ (name "tryton")
+ (version "4.4.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://downloads.tryton.org/4.4/tryton-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1lklcz5fs6rkrd7z2m2f5gz4fdwzkgnhg2hyvzp20kdsvi33bq2j"))))
+ (build-system python-build-system)
+ (inputs
+ `(("python2-chardet" ,python2-chardet)
+ ("python2-dateutil" ,python2-dateutil)
+ ("python2-pygtk" ,python2-pygtk)))
+ (arguments
+ `(#:python ,python-2))
+ (home-page "https://www.tryton.org/")
+ (synopsis "Client component of Tryton")
+ (description "This package is the client component of Tryton.")
+ (license license:gpl3+)))