summaryrefslogtreecommitdiff
path: root/gnu/packages/tryton.scm
diff options
context:
space:
mode:
authorAdriano Peluso <catonano@gmail.com>2017-05-20 08:21:31 +0200
committerArun Isaac <arunisaac@systemreboot.net>2017-05-27 18:41:12 +0530
commit48174fb9aacd2a9c52edf769094481bc9ba03003 (patch)
tree3a99b94351064035b53e1fb9c3692216f9bd41b1 /gnu/packages/tryton.scm
parentecca63b654da9ca283dc2d04fa03ce3dd61c811d (diff)
downloadguix-patches-48174fb9aacd2a9c52edf769094481bc9ba03003.tar
guix-patches-48174fb9aacd2a9c52edf769094481bc9ba03003.tar.gz
gnu: Add trytond.
* gnu/packages/tryton.scm: New file. * gnu/local.mk (GNU_SYSTEM_MODULES): Add it. * gnu/packages/tryton.scm (trytond): New variable. Signed-off-by: Arun Isaac <arunisaac@systemreboot.net>
Diffstat (limited to 'gnu/packages/tryton.scm')
-rw-r--r--gnu/packages/tryton.scm67
1 files changed, 67 insertions, 0 deletions
diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
new file mode 100644
index 0000000000..590bd54382
--- /dev/null
+++ b/gnu/packages/tryton.scm
@@ -0,0 +1,67 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2017 Adriano Peluso <catonano@gmail.com>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages tryton)
+ #:use-module ((guix licenses) #:prefix license:)
+ #:use-module (gnu packages)
+ #:use-module (gnu packages python)
+ #:use-module (guix packages)
+ #:use-module (guix download)
+ #:use-module (guix build-system python))
+
+(define-public trytond
+ (package
+ (name "trytond")
+ (version "4.4.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://downloads.tryton.org/4.4/trytond-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "15gm34qwj5fpnkqvrxzndl8653zbczhsa76dm1gi4cqj1r29bbpr"))))
+ (build-system python-build-system)
+ (inputs
+ `(("python-dateutil" ,python-dateutil)
+ ("python-genshi" ,python-genshi)
+ ("python-polib" ,python-polib)
+ ;; there's no python-mysql in Guix right now
+ ;; so python-psycopg2 (postgresql) only for now
+ ("python-psycopg2" ,python-psycopg2)
+ ("python-relatorio" ,python-relatorio)
+ ("python-lxml" ,python-lxml)
+ ("python-sql" ,python-sql)
+ ("python-werkzeug" ,python-werkzeug)
+ ("python-wrapt" ,python-wrapt)))
+ (native-inputs
+ `(("python-mock" ,python-mock)))
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-before 'check 'preparations
+ (lambda _
+ (setenv "DB_NAME" ":memory:"))))))
+ (home-page "https://www.tryton.org/")
+ (synopsis "Server component of Tryton")
+ (description "Tryton is a three-tier high-level general purpose
+application platform using PostgreSQL as its main database engine. It is the
+core base of a complete business solution providing modularity, scalability
+and security.")
+ (license license:gpl3+)))