summaryrefslogtreecommitdiff
path: root/gnu/packages/tor.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-03-01 16:31:06 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2018-03-01 22:21:01 +0100
commit68e7632db052105b70704cd2c1cc42a568e9bf4a (patch)
tree20f75feec8fa55b7c2fb3d65edafc768beaafdb3 /gnu/packages/tor.scm
parentfbb0164a5f7087a81ef5f79a4134432969f926cf (diff)
downloadguix-patches-68e7632db052105b70704cd2c1cc42a568e9bf4a.tar
guix-patches-68e7632db052105b70704cd2c1cc42a568e9bf4a.tar.gz
gnu: onionshare: Update phase style.
* gnu/packages/tor.scm (onionshare)[arguments]: Substitute INVOKE for SYSTEM* and end phase with #t.
Diffstat (limited to 'gnu/packages/tor.scm')
-rw-r--r--gnu/packages/tor.scm4
1 files changed, 3 insertions, 1 deletions
diff --git a/gnu/packages/tor.scm b/gnu/packages/tor.scm
index f598672d91..50295da5dc 100644
--- a/gnu/packages/tor.scm
+++ b/gnu/packages/tor.scm
@@ -231,7 +231,9 @@ networks.")
;; After all the patching we run the tests after installing.
;; This is also a known issue:
;; https://github.com/micahflee/onionshare/issues/284
- (lambda _ (zero? (system* "nosetests" "test")))))))
+ (lambda _
+ (invoke "nosetests" "test")
+ #t)))))
(native-inputs
`(("python-nose" ,python-nose)))
(inputs