summaryrefslogtreecommitdiff
path: root/gnu/packages/tls.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-08-03 16:12:59 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-08-03 16:12:59 -0400
commitd0cc63ccc53cb2ad4d33d0a54f079089d5b6cd46 (patch)
tree93a95035d8bc1f8b80398cd1360df551330268b0 /gnu/packages/tls.scm
parent77e2df870bdd3605925b78642661e252a83b2369 (diff)
downloadguix-patches-d0cc63ccc53cb2ad4d33d0a54f079089d5b6cd46.tar
guix-patches-d0cc63ccc53cb2ad4d33d0a54f079089d5b6cd46.tar.gz
gnu: dehydrated: Follow up commit to 77e2df870b.
* gnu/packages/tls.scm (dehydrated): Remove bogus, nested native-search-paths.
Diffstat (limited to 'gnu/packages/tls.scm')
-rw-r--r--gnu/packages/tls.scm15
1 files changed, 7 insertions, 8 deletions
diff --git a/gnu/packages/tls.scm b/gnu/packages/tls.scm
index 6b74d55a7d..d98a724b5f 100644
--- a/gnu/packages/tls.scm
+++ b/gnu/packages/tls.scm
@@ -1085,15 +1085,14 @@ coding footprint.")
(native-inputs
`(("gzip" ,gzip)
("tar" ,tar)))
+ ;; The following definition is copied from the cURL package to prevent a
+ ;; cycle between the curl and tls modules.
(native-search-paths
- ;; The following definition is copied from the cURL package to prevent a
- ;; cycle between the curl and tls modules.
- (native-search-paths
- (list (search-path-specification
- (variable "CURL_CA_BUNDLE")
- (file-type 'regular)
- (separator #f)
- (files '("etc/ssl/certs/ca-certificates.crt"))))))
+ (list (search-path-specification
+ (variable "CURL_CA_BUNDLE")
+ (file-type 'regular)
+ (separator #f)
+ (files '("etc/ssl/certs/ca-certificates.crt")))))
(home-page "https://dehydrated.io/")
(synopsis "Let's Encrypt/ACME client implemented as a shell script")
(description "Dehydrated is a client for signing certificates with an