summaryrefslogtreecommitdiff
path: root/gnu/packages/tls.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-03-15 01:25:56 +0100
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-08-03 15:47:06 -0400
commit77e2df870bdd3605925b78642661e252a83b2369 (patch)
tree36bb4ade0202c86e9a3a97d6b0fd883c6970eaa6 /gnu/packages/tls.scm
parentc40516a567d21301399891d9a67924a1da606c71 (diff)
downloadguix-patches-77e2df870bdd3605925b78642661e252a83b2369.tar
guix-patches-77e2df870bdd3605925b78642661e252a83b2369.tar.gz
gnu: dehydrated: Declare cURL's native search paths.
* gnu/packages/tls.scm (dehydrated)[native-search-paths]: Use curl's. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
Diffstat (limited to 'gnu/packages/tls.scm')
-rw-r--r--gnu/packages/tls.scm11
1 files changed, 10 insertions, 1 deletions
diff --git a/gnu/packages/tls.scm b/gnu/packages/tls.scm
index 3e202a901b..6b74d55a7d 100644
--- a/gnu/packages/tls.scm
+++ b/gnu/packages/tls.scm
@@ -10,7 +10,7 @@
;;; Copyright © 2016 Hartmut Goebel <h.goebel@crazy-compilers.com>
;;; Copyright © 2017 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2017, 2018, 2019, 2020, 2021 Marius Bakke <marius@gnu.org>
-;;; Copyright © 2017–2019, 2021 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2017–2021 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2017 Rutger Helling <rhelling@mykolab.com>
;;; Copyright © 2018 Clément Lassieur <clement@lassieur.org>
;;; Copyright © 2019 Mathieu Othacehe <m.othacehe@gmail.com>
@@ -1085,6 +1085,15 @@ coding footprint.")
(native-inputs
`(("gzip" ,gzip)
("tar" ,tar)))
+ (native-search-paths
+ ;; The following definition is copied from the cURL package to prevent a
+ ;; cycle between the curl and tls modules.
+ (native-search-paths
+ (list (search-path-specification
+ (variable "CURL_CA_BUNDLE")
+ (file-type 'regular)
+ (separator #f)
+ (files '("etc/ssl/certs/ca-certificates.crt"))))))
(home-page "https://dehydrated.io/")
(synopsis "Let's Encrypt/ACME client implemented as a shell script")
(description "Dehydrated is a client for signing certificates with an