summaryrefslogtreecommitdiff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-04-14 17:25:30 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-12 12:45:47 -0400
commitefb791ba4f3559ca9306289889af02da96b822f3 (patch)
treef25400f08d6a1708d6e7b97f09c9812aae45a971 /gnu/packages/tex.scm
parent7e679ea7f71abf233512c30cf2a951dfe3f03f6b (diff)
downloadguix-patches-efb791ba4f3559ca9306289889af02da96b822f3.tar
guix-patches-efb791ba4f3559ca9306289889af02da96b822f3.tar.gz
gnu: python-sphinx: Propagate TexLive dependencies.
* gnu/packages/sphinx.scm (python-sphinx): [propagated-inputs]: Add texlive-amsfonts, texlive-amsmath, texlive-capt-of, texlive-carlisle, texlive-etoolbox, texlive-generic-ltxcmds, texlive-hyperref, texlive-latex-base, texlive-latex-cmap, texlive-latex-fancyhdr, texlive-latex-fancyvrb, texlive-latex-fncychap, texlive-latex-float, texlive-latex-framed, texlive-latex-geometry, texlive-latex-graphics, texlive-latex-kvoptions, texlive-latex-needspace, texlive-latex-parskip, texlive-latex-preview, texlive-latex-tabulary, texlive-latex-titlesec, texlive-latex-tools, texlive-latex-upquote, texlive-latex-varwidth, texlive-oberdiek, texlive-stringenc, texlive-wrapfig, texlive-xcolor and texlive-zapfding. [native-inputs]: Remove graphviz, python-mock and python-nose. * gnu/packages/tex.scm (texlive-xcolor): Add TODO comment. * gnu/packages/tex.scm (texlive-hyperref): Likewise.
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm11
1 files changed, 10 insertions, 1 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index a861b40950..0aa6a8bf95 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -3326,6 +3326,9 @@ used by @code{hyperref} and @code{bookmark}.")
(rename-file (string-append share "/tex/latex/xcolor/xcolor.pro")
(string-append share "/dvips/xcolor/xcolor.pro"))
#t)))))))
+ ;; TODO: Propagate texlive-hyperref and many others in the next rebuild
+ ;; cycle. Grep for '\usepackage' to see what packages it requires.
+ ;; (propagated-inputs (list texlive-hyperref ...))
(home-page "https://www.ctan.org/pkg/xcolor")
(synopsis "Driver-independent color extensions for LaTeX and pdfLaTeX")
(description
@@ -3449,7 +3452,13 @@ XML, using UTF-8 or a suitable 8-bit encoding.")
texlive-latex-pdftexcmds
texlive-latex-refcount
texlive-latex-rerunfilecheck
- texlive-url))
+ texlive-url
+ ;; TODO: Add this in next rebuild cycle.
+ ;;texlive-cm
+ ;;texlive-latex-graphics ;for keyval
+ ;;texlive-stringenc
+ ;;texlive-zapfding
+ ))
(home-page "https://www.ctan.org/pkg/hyperref")
(synopsis "Extensive support for hypertext in LaTeX")
(description